This project is read-only.

Problem encoding a movies from the beginning.

May 31, 2011 at 11:38 AM

Been using VidCoder for a while now and haven't had any problems till now.

Just finished pass one of two passes of a movie. About 2% into the second pass I checked the encode and it stared half way through the movie instead of at the beginning.

Will start the encode again when I get the time and see what happens this time.



May 31, 2011 at 3:34 PM

Are you ripping a DVD? How could you tell it was encoding the second half when it was only 2% done? Can you send me the preset you're using?

May 31, 2011 at 11:52 PM

Hi Random

Ripping a Blu-ray which was copied to the HDD. I just click on the second pass encode with S-Player (my system multimedia player). That way I can tell how my encode is going to turn out.

Currently doing a different movie which is ok when I checked.

Will try the problem movie again after the current one is finished.


Jun 2, 2011 at 11:08 AM
Edited Jun 2, 2011 at 1:46 PM

A different problem this time. While encoding about 30% on the first pass, VidCoder just exited. No explanation. This has happen twice so far. Will try again. Maybe third time lucky.

Jun 2, 2011 at 3:31 PM

Don't know. I have been seeing some problems with MKV output on the x86 build. Something weird must be going on in the HandBrake core.

Jun 4, 2011 at 1:22 AM


There also seems to be a problem adjusting the file size.

If you adjust the file size increments too quickly the program crashes.

Example. As you adjust the size tab the bit-rate also adjusts automatically which is nice. However, when I adjust the size tab to over 2 gig the bit-rate drops to zero. If you try to adjust the size of the file to quickly by holding down the size tab the program crashes.

Jun 4, 2011 at 7:25 AM

The size tab? Don't know what you're referring to there. I've tried holding down the up or down buttons on the file size control but I'm not getting a crash. Do you get any details?

Jun 4, 2011 at 9:32 AM


The target file size has an up and down arrow. If you hold the up arrow down the files size target goes up. At the same time an average bit rate number appears in the average bit rate box. Once the files size gets to +2000 (mb) the the number in the average bit rate box goes to zero. If you hold the file size up arrow down continuously the file size goes up quickly and the program crashes. It exits to the desktop no explanation.

As long as I limit the target files size to no more than 2000 the encode completes ok, If I go over 2000 with the average bit rate box resetting to zero. The encode crashes halfway through.


This may only happen on my system for some reason. Win 7 x86. All windows updates included.

Jun 4, 2011 at 4:48 PM

I see what you mean about the file size being limited to 2000. Thanks for the report; this will be fixed in the next version. But I can't replicate your crash. It works fine when I hold down the up arrow. How does it crash for you? Do you get an informative dialog with error details, or is it just a "this program blew up" box?

Jun 5, 2011 at 8:22 AM

Nah, no messages. Just goes to desktop. When I hold down the arrow and the bit rate changes quickly I hear the harddrive thrash and then it crashes. Currently encoding a file over 3 gig so I'll see how it goes. Previous attempts have crashed at various stages of the encodes when the AB box is zero.

Jun 5, 2011 at 1:15 PM
Edited Jun 5, 2011 at 1:16 PM

Well, encode was set at 3.2 gig (file size) and ave bit-rate zero, Finished first pass - crashed at start of second pass.

Now trying same encode with 2 pass/ Average bit-rate of 2800. If this doesn't crash then it appears that the cause has something to do with the zero/AB ( as I explained above).

Jun 5, 2011 at 6:56 PM

Yeah the crash is probably because 0 got passed in as the bitrate. Will be fixed in next version.

Jun 6, 2011 at 12:54 AM

Encode with 2 pass/ Average bit-rate of 2800 crashed as well. When I went to bed nearly finished first pass. Checked in morning - VidCoder exited.

Will now use an older version until new one comes out.

Jun 8, 2011 at 5:42 AM

Should be fixed in 0.9.2.

Jun 8, 2011 at 10:54 PM

I have the same from problem for the moment :)

Jun 9, 2011 at 12:21 AM
Edited Jun 9, 2011 at 12:22 AM

Using 9.2 now.

Increasing the file size box no longer affects the Ave Bit-rate box. Tried an encoder (2 pass) over 2000 and completed ok. No probs.



Jun 9, 2011 at 12:31 AM

Try switching to average bitrate then back to target size. It should update then. I'll fix that little bug next version.