This project is read-only.

Unable To Run Vidcoder Any More :-(

Aug 21, 2011 at 11:56 AM


I tried to use Vidcoder last night & got loads of strange errors (never wrote them down) so decided to uninstall completely (deleted directories after) and downloaded the latest x64 version for my win 7 X64 and after installation I get the following error log and cannot run Vidcoder


System.Configuration.ConfigurationErrorsException: Configuration system failed to initialize ---> System.Configuration.ConfigurationErrorsException: Root element is missing. (C:\Users\INTELQUAD\AppData\Local\VidCoder\VidCoder.exe_Url_mhzbupc0u3lwyg3njblphqzqwm434ah1\\user.config) ---> System.Xml.XmlException: Root element is missing.
   at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo(String res)
   at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
   at System.Configuration.XmlUtil..ctor(Stream stream, String name, Boolean readToFirstElement, ConfigurationSchemaErrors schemaErrors)
   at System.Configuration.BaseConfigurationRecord.InitConfigFromFile()
   --- End of inner exception stack trace ---
   at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal)
   at System.Configuration.BaseConfigurationRecord.ThrowIfParseErrors(ConfigurationSchemaErrors schemaErrors)
   at System.Configuration.ClientConfigurationSystem.OnConfigRemoved(Object sender, InternalConfigEventArgs e)
   --- End of inner exception stack trace ---
   at System.Configuration.ConfigurationManager.GetSection(String sectionName)
   at System.Configuration.PrivilegedConfigurationManager.GetSection(String sectionName)
   at System.Diagnostics.DiagnosticsConfiguration.Initialize()
   at System.Diagnostics.DiagnosticsConfiguration.get_Sources()
   at System.Diagnostics.TraceSource.Initialize()
   at System.Net.Logging.InitializeLogging()
   at System.Net.Logging.get_On()
   at System.Net.WebRequest.Create(Uri requestUri, Boolean useUriBase)
   at MS.Internal.WpfWebRequestHelper.CreateRequest(Uri uri)
   at System.Windows.Media.ColorContext.Initialize(Uri profileUri, Boolean isStandardProfileUriNotFromUser)
   at System.Windows.Media.ColorContext..ctor(PixelFormat pixelFormat)
   at System.Windows.Media.Imaging.BitmapSource.CreateCachedBitmap(BitmapFrame frame, BitmapSourceSafeMILHandle wicSource, BitmapCreateOptions createOptions, BitmapCacheOption cacheOption, BitmapPalette palette)
   at System.Windows.Media.Imaging.BitmapFrameDecode.FinalizeCreation()
   at System.Windows.Media.Imaging.BitmapDecoder.SetupFrames(BitmapDecoder decoder, ReadOnlyCollection`1 frames)
   at System.Windows.Media.Imaging.BitmapDecoder.get_Frames()
   at System.Windows.Media.Imaging.BitmapFrame.CreateFromUriOrStream(Uri baseUri, Uri uri, Stream stream, BitmapCreateOptions createOptions, BitmapCacheOption cacheOption, RequestCachePolicy uriCachePolicy)
   at System.Windows.Media.ImageSourceConverter.ConvertFrom(ITypeDescriptorContext context, CultureInfo culture, Object value)

Aug 21, 2011 at 12:13 PM

If It Helps, I have just downloaded the x86 version and that works fine.... ??

Aug 21, 2011 at 5:29 PM

Looks like something got messed up with your user config file. What I would try is start->run %localappdata%\VidCoder then delete all folders there. That would clean out whatever was corrupt. The reason the x86 version would work is that it's using a different non-corrupt user config file.

Also strangely I don't see any part of my code in that stack trace. Did you paste the full trace or just the top of it?

Aug 21, 2011 at 11:05 PM

That trace was complete mate....

will try what you said now

Aug 21, 2011 at 11:06 PM

yep! deleting those files worked... :-) Thanks Mate,,,

Sep 14, 2011 at 7:14 PM

That's the ticket!  This needs to be on a FAQ, if it isn't already.  I uninstalled everything and still had the issue, until I nuked that dir.

Sep 14, 2011 at 8:31 PM


I've downloaded last version 1.0.2 but after install, vidcoder don't start. Ok for splash screen then stop.Version 1.0 start and work fine


Sep 14, 2011 at 8:35 PM

That sucks. :(

Did you get an error message? Is it the same as this one? On all of my test machines the upgrade seems to have gone smoothly. Are you using the x86 or x64 version?

Sep 14, 2011 at 8:46 PM

This appear after splash screen:

Firma problema:
  Nome evento problema:    CLR20r3
  Firma problema 01:    vidcoder.exe
  Firma problema 02:
  Firma problema 03:    4e6eddcc
  Firma problema 04:    mscorlib
  Firma problema 05:
  Firma problema 06:    4da3fe76
  Firma problema 07:    e48
  Firma problema 08:    0
  Firma problema 09:    System.StackOverflowException
  Versione SO:    6.1.7601.
  ID impostazioni locali:    1040
  Informazioni aggiuntive 1:    3a90
  Ulteriori informazioni 2:    3a90e4cbbc31174660ec2ad3d591ac3a
  Ulteriori informazioni 3:    a80d
  Ulteriori informazioni 4:    a80d31f9a432fbef0af61904e5a91538

I'm using x86 version on windows 7 32 bit version.

Rollback vidcoder 1.0 works ok.

Sep 14, 2011 at 8:51 PM

Ahh, a stack overflow. So it's different than the original problem. I'll have to try and figure out where this could be happening. You could try deleting all files in %localappdata%\VidCoder and %appdata%\VidCoder (be sure to back up your VidCoder.sqlite if you want to save your presets). If you told me what happened after you did that it would help narrow down the problem.

Sep 14, 2011 at 9:01 PM

Now vidcoder start ok, thanks a lot !

my old VidCoder.sqlite crash vidcoder too and so, my personal setting (specially for pal colorimetry) are lost.

It seems incompatible with vidcoder 1.0.2

Sep 14, 2011 at 9:03 PM

If you could send me your old VidCoder.sqlite file I'd be able to get to the bottom of this (and maybe get you your presets back).

Sep 14, 2011 at 9:12 PM

not problem

I'm work for new preset again for option string, I'm just deleted oldvidcoder.sqlite

Possible to use picture setting like colorimetry, color matrix, trasnfer and tuning (animation, film) in GUI ?

Sep 14, 2011 at 9:15 PM

Sure it's possible! I just don't have any idea what the GUI should look like. If you could give me a few more details about what you were expecting I might be able to help you out.

And I really would like to see the old VidCoder.sqlite you had... if you had this problem then other people are probably running into it and this would help me squash that bug.

Sep 14, 2011 at 9:29 PM

Now download vidcoder 1.0 again and install, then 1.0.2. for possible errors. My VidCoder.sqlite is deleted now and wrote again my string in advanced option.

This is my string:


For I'm expect a simple menu on the right of varius setting (motion extimation search ect) with picture setting and tuning (animation, film, gain). They are x264 option and handbrake can use it now in cli format or advanced string in gui.

I've used my string for vidcoder too and works fine ! (lib are same)

colormatrix and video format are not recognized for PAL version, their values are wrong, but works ok with my string (I'm upscale my dvd into hd ready format).

Please, give me some time to reinstall old version

Sep 14, 2011 at 9:35 PM


I'm rollback to 1.0 version and then 1.0.2. Start ok now.

No errors for stack overflow.

Sep 14, 2011 at 9:39 PM

Oh well, thanks for trying. Anyway to make a UI for the videoformat/colorprim/colormatrix/transfer I'd need to know what all the possible values are and hopefully some explanation behind each of the settings.

Sep 14, 2011 at 9:50 PM


for video format:


Default: undef

Indicates what the video was before encoding/digitizing.

Possible Values:

  • component
  • pal
  • ntsc
  • secam
  • mac
  • undef

for colorprim:


Default: undef

Set what color primaries for converting to RGB.

Possible Values:

  • undef
  • bt709
  • bt470m
  • bt470bg
  • smpte170m
  • smpte240m
  • film

for transfer:



Default: undef

Set the opto-electronic transfer characteristics to use. (Sets the gamma curve to use for correction.)

Possible Values

  • undef
  • bt709
  • bt470m
  • bt470bg
  • linear
  • log100
  • log316
  • smpte170m
  • smpte240m

for colormatrix:


Default: undef

Set the matrix coefficients used in deriving the luma and chroma from the RGB primaries.

Possible Values

  • undef
  • bt709
  • fcc
  • bt470bg
  • smpte170m
  • smpte240m
  • GBR
  • YCgCo

very usefull, like x264 vfw version are tuning, but I don't know if these values work for now.

However they are:


Default: Not Set

Tune options to further optimize them for your input content. If you specify a tuning, the changes will be applied after --preset but before all other parameters.

If your source content matches one of the available tunings you can use this, otherwise leave unset.

Values available: film, animation, grain, stillimage, psnr, ssim, fastdecode, zerolatency.


Sep 14, 2011 at 10:25 PM

Yeah I don't know if it's actually possible to pass tune to libhb. As for the others, that's a lot closer but we'd need friendly names for each choice. For example under Motion Estimation Method, one of the choices is Uneven Multi-Hexagon (even though its value is actually umh). I'd like to be able to at least explain a little what "bt470bg" is. Also, what's the video format used for? It it a hint for the input or some directions for how to format the output?

Sep 14, 2011 at 10:44 PM
Edited Sep 14, 2011 at 10:53 PM

first of all:

video format are used usually for SD version. 480 or 576, normally dvd conversion 1:1, no sense for 720 or higher resolution.

normally handbrake or vidcoder give bad colorimeetry information for PAL DVD and must be set by hand.

bt470bg is color space parameters information about stream.

I suggest to you read here some itu-r recommendation:

maybe can help you better than me, specially for presets.

VFW x264 codes use a square called VUI.

inside there are possible choices:

videoformat: undef, component, ntsc, secam, mac (menu with possible values)

full range:on, off, (default on, meni with possible values)

color primaries: undef, bt709, bt470m, bt470bg, smpte170m, smpte240m, film (menu with possible values)

transfer characteristics:  bt709, bt470m, bt470bg, smpte170m, smpte240m, linear, log100, log316 (menu with possible values)

color matrix: undef, bt709, fcc, bt470bg, smpte170m, smpte240m, YCgCo, GBR. (menu with possible values)

chroma sampling location (default=0)


Sep 14, 2011 at 11:47 PM

I don't think you gave me the right link there about ITU-R. It's talking about satellites. And I do not believe you understood my request about friendly names. You seem to just have repeated the unfriendly ones.

Sep 16, 2011 at 7:19 PM

Hi, randomengy

i've another crash everytime I star vidcoder. Stack overflow again. If deleted "VidCoder.sqlite", start ok.

I've backup file, can help you to resolve ?

Sep 16, 2011 at 11:21 PM

Yeah send me the problematic file. I'll take a look at it.

Sep 16, 2011 at 11:44 PM

Sep 17, 2011 at 12:00 AM

Fantastic. I've reproduced the problem. Should be fixed in no time.

Though next time remember you can share files via Dropbox rather than those sites that make you enter a captcha and wait 40 seconds before starting a slow download.

Sep 17, 2011 at 12:28 AM

ok !

thanks for fix and patience !

Sep 17, 2011 at 12:31 AM

And fixed in 1.0.3. You should be able to install manually and start up without the crash.

Sep 17, 2011 at 12:58 AM

Now works ok !

no crash and remember queues.

Thanks a lot !

I've another question, not very important, for vidcoder: Are you able to add a driver for external h264 hardware encoder using free SDK instead x264lib ? I ask like alternative choice. I know that's off topic.

Sep 17, 2011 at 1:07 AM

That's up to the HandBrake team. I won't be doing any of that work myself.

Sep 17, 2011 at 1:16 AM

HandBrake team rejected my request. But it's not very important, i'm using external encoder in cli mode for my hardware card.

Thanks again for fix my problem !