Subtitles

Apr 14, 2013 at 2:43 PM
Hi!
I imported a blu-ray in VidCoder.
I selected 2 audio's
Why i can't select 2 subtitles? Why only one subtitle , and that subtitle is burned on the image. I tested that.
Blu-ray subtitles are .sup. It would be awesome to give us an option to extract and convert subtitles to .idx/.sub.
Hybrid gives us this option. You can find the software here:
http://www.selur.de/
I want this option in VidCoder because in Hybrid it takes a loooot of time to convert to the final mp4. VidCoder is fast and has a nice interface.
Or some option to import the .idx/.sub.
Thanks!
Coordinator
Apr 14, 2013 at 4:58 PM
Well with PGS subtitles in 1.4.18 Beta I don't have any trouble including multiple tracks. Can you send a scan log and include a screenshot of the subtitle dialog?

As far as extracting subtitles, that's not in the HandBrake API so I can't do it.
Apr 14, 2013 at 7:28 PM
Coordinator
Apr 14, 2013 at 8:26 PM
Oh sorry about that; I always forget about these subtitle restrictions after I implement them. That's a limitation of the MP4 container: you can't have soft-subs of PGS. If you choose MKV you'll be able to specify multiple subtitles.
Apr 15, 2013 at 4:19 AM
Ok i Choosed MKV. Look at this sample video:
https://mega.co.nz/#!D4xTBRDS!CG9k5w4WP9eIKDgO0GxGLAHHQkkz42uw16G1x82JtjY

Subtitle are not shown as it should be, I;ve tried with VLC 2.0.6 and Mac Blu-ray Player
Coordinator
Apr 15, 2013 at 6:36 AM
Sometimes the subtitles don't come out right when you encode a small clip. See what happens when you do the whole title. If it's still broken see if it's also broken with the latest HandBrake nightly.
Apr 16, 2013 at 9:35 AM
Edited Apr 16, 2013 at 9:36 AM
I figured out why the subtitle is not shwon as it shoud be because .sup and .sub subtiles are images made for 1080p. They must me converted in a subtitle editor to 720p.
Okay, I give up at .sup and .sub.
I tried with .srt and every time enoding fails.
Here is a log:
https://mega.co.nz/#!f1JzxD4J!PnwJfgg89G--rmS_acDfTxjsGwpoCTDL0aiXXDRAkG0

And here is the subtitle:
https://mega.co.nz/#!bs5xHDjD!F_oHBx6UyhR8UV5iAL_iqDVujYd-TBbHQY1tNBPgVnY

I tried changing the framerate to 23.976 and it not worked either.
Here is the subtitles options:
http://s19.postimg.org/3rwsgursj/vidcoder_subtitles.png

I don't know what am I doing wrong.
The subtitle is in romanian.
Even if it failed the video was created, but diacritics are not shown at all, not even replaces by other letters.

Here is an image:
http://s19.postimg.org/l6h0p4oxf/vidcoder_subtitles_2.png

The text from the image should be:
"Ești sigur că ești pregătit?"

Please help me. Thanks
Coordinator
Apr 16, 2013 at 3:03 PM
I just write the UI! Please try it with HandBrake. I don't know why it would fail but it looks like VidCoder is passing the encoding parameters to HandBrake correctly.
Apr 16, 2013 at 7:26 PM
Edited Apr 16, 2013 at 7:29 PM
You just wrote the UI of a new version?
I will try with Handbrake
From this link it looks like the svn5400 is the latest stable:
https://build.handbrake.fr/view/All/job/WindowsGui64/lastStableBuild/
I'm not sure.
Coordinator
Apr 16, 2013 at 9:13 PM
I'm saying that HandBrake handles the actual encoding, including the subtitles, VidCoder just passes that information to HandBrake. And yes, it looks like 5400 would be the one you want.
Apr 17, 2013 at 3:15 AM
Edited Apr 17, 2013 at 3:16 AM
What I don't like at handbrake is :
-no target file size
-You can't put a larger resolution then the input
Apr 17, 2013 at 4:19 AM
So i uninstalled VidCoder with Revo Uninstaller 3 and cleaned the leftovers of VidCoder.
I reinstalled VidCoder and i encoded the full movie with 2 subtitles
-Romanian. I've set char code : ISO-8859-16
Iv've find out the char code from here:
http://en.wikipedia.org/wiki/Character_encoding
Now it shows subtitle as it should be with diacritics. Aleluia!
-English. I've let the default char-code: UTF-8
The conversion "Succeeded". No failure.
What filesze do you recommend for HD 720p with 2 audio's and 2 .srt subtitles?
Coordinator
Apr 17, 2013 at 5:53 AM
Edited Apr 17, 2013 at 5:53 AM
I'm not saying to use HandBrake instead, I'm saying you should test against it to see if the problem is VidCoder specific. If it happens in HandBrake you should ask them to fix it, then the fix will show up in VidCoder.

As for the encoding settings, I recommend you use Constant Quality 20. See this page explaining it: https://vidcoder.codeplex.com/wikipage?title=Video%20Quality%20Options
Apr 18, 2013 at 4:03 AM
I don't need to try Handbrake because I've fixed the problem by completly uninstall VidCoder and reinstall it. I've never received failure again.
Dec 30, 2013 at 10:47 AM
Edited Dec 30, 2013 at 11:00 AM
Hi

Just had the same problem and it seem to be related to the UTF-8 marker VidCoder seems to be expecting in the srt subtitle file. UTF-8 specifies that it can be used without this marker (and frequently is) but the result is that a program reading it cannot determine relaliable if it's UTF-8.

If you edit the srt file and save it as UTF-8 with good old Notepad it will have the 3 byte UTF-8 marker (0xEF 0xBB 0xBF) inserted and the
'Invalid byte for codeset in input, discard byte' error will dissapear.

But i still do not see subs when playing the the mediaplayer.

When i read the handbrake wiki it seems like srt files are never burned in (only ssa). So why is there no ssa import/
support?

regards
wvdv
Coordinator
Dec 31, 2013 at 6:00 PM
Good find on the UTF-8 marker. Don't know why there's no SSA import. Maybe you can ask them.
Thu at 4:26 AM
Hi blagasamuel

I have also encountered this problem, but my friend gave me a moment to re-install, set up click on it, the problem should not be difficult.
The best way to do this is using the "MTS to MOV Converter," a Windows- and Macintosh-compatible software suite developed by MTS to MOV.
I would recommend you also try mts to mov converter which is free to download trial software.

http://www.mtstomov.com/

You can try!