MP4 files starting to get way too big from dvd iso conversions...

Jul 4, 2013 at 2:23 AM
For some reason using both the latest release and also the beta versions, the output files are getting way too big.

The usual output size was between 500mb to 1.5gb per disc, however now every disc has the output size over 11gb using the same settings. Ive tried resetting the settings to basic and its still doing this.
Coordinator
Jul 4, 2013 at 3:00 AM
Can you provide an encode log?
Jul 4, 2013 at 3:43 AM
Heres the log after trying to convert an iso to mp4 after a fresh install using the default normal preset. After a couple mins I stopped it after the file reached 1gb at only 10mins of video converted. It started doing this after I tried to add a ton of files in a queue to be converted. Tried uninstalling and reinstalling but it doesnt help

VidCoder 1.5.2.0 (x64)

Starting queue

VidCoder 1.5.2.0 (x64)

Starting job 1/11

Path: M:\DVDS\xxxxxxxxx.ISO

Title: 22

Range: All

Worker ready: Service state is Opened on pipe VidCoderWorker.bfc9a43e-24f4-4cd7-b29e-d0ad4e2d840d

Connecting to process 2528 on pipe VidCoderWorker.bfc9a43e-24f4-4cd7-b29e-d0ad4e2d840d

[21:35:05] hb_init: starting libhb thread
[21:35:05] hb_scan: path=M:\DVDS\CHUMSCRUBBER.ISO, title_index=22
libbluray/bdnav/index_parse.c:162: indx_parse(): error opening M:\DVDS\xxxxxxxxxxx.ISO/BDMV/index.bdmv
libbluray/bdnav/index_parse.c:162: indx_parse(): error opening M:\DVDS\xxxxxxxxxx.ISO/BDMV/BACKUP/index.bdmv
libbluray/bluray.c:1725: nav_get_title_list(M:\DVDS\xxxxxxxxxxx.ISO) failed (0000000000981170)
[21:35:05] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 4.1.3
libdvdread: Encrypted DVD support unavailable.
libdvdnav: DVD Title: xxxxxxxxxx
libdvdnav: DVD Serial Number: xxxxxxxxxxx
libdvdnav: DVD Title (Alternative):
libdvdnav: Unable to find home directorylibdvdnav: DVD disk reports itself with Region mask 0x00c00000. Regions: 1 2 3 4 5 6
libdvdread: Encrypted DVD support unavailable.
[21:35:05] scan: DVD has 25 title(s)
[21:35:05] scan: scanning title 22
[21:35:05] scan: opening IFO for VTS 8
[21:35:05] scan: duration is 01:47:14 (6434867 ms)
[21:35:05] pgc_id: 1, pgn: 1: pgc: 00000000009939D0
[21:35:05] scan: vts=8, ttn=1, cells=0->17, blocks=14->2017495, 2017482 blocks
[21:35:05] scan: checking audio 1
[21:35:05] scan: id=0x80bd, lang=English (AC3), 3cc=eng ext=0
[21:35:05] scan: checking audio 2
[21:35:05] scan: audio channel is not active
[21:35:05] scan: checking audio 3
[21:35:05] scan: audio channel is not active
[21:35:05] scan: checking subtitle 1
[21:35:05] scan: id=0x20bd, lang=English, 3cc=eng ext=1
[21:35:05] scan: checking subtitle 2
[21:35:05] scan: id=0x21bd, lang=Francais, 3cc=fra ext=1
[21:35:05] scan: checking subtitle 3
[21:35:05] scan: id=0x22bd, lang=Espanol, 3cc=spa ext=1
[21:35:05] scan: title 22 has 17 chapters
[21:35:05] scan: chap 1 c=0->0, b=14->121143 (121130), 382867 ms
[21:35:05] scan: chap 2 c=1->1, b=121144->273277 (152134), 460633 ms
[21:35:05] scan: chap 3 c=2->2, b=273278->470299 (197022), 551333 ms
[21:35:05] scan: chap 4 c=3->3, b=470300->660880 (190581), 621166 ms
[21:35:05] scan: chap 5 c=4->4, b=660881->744256 (83376), 271667 ms
[21:35:05] scan: chap 6 c=5->6, b=744257->880575 (136319), 429834 ms
[21:35:05] scan: chap 7 c=7->7, b=880576->989623 (109048), 345333 ms
[21:35:05] scan: chap 8 c=8->8, b=989624->1167858 (178235), 490033 ms
[21:35:05] scan: chap 9 c=9->9, b=1167859->1282925 (115067), 333300 ms
[21:35:05] scan: chap 10 c=10->10, b=1282926->1348944 (66019), 223500 ms
[21:35:05] scan: chap 11 c=11->11, b=1348945->1490447 (141503), 465500 ms
[21:35:05] scan: chap 12 c=12->12, b=1490448->1607036 (116589), 388200 ms
[21:35:05] scan: chap 13 c=13->13, b=1607037->1685715 (78679), 258967 ms
[21:35:05] scan: chap 14 c=14->14, b=1685716->1862018 (176303), 509033 ms
[21:35:05] scan: chap 15 c=15->15, b=1862019->1970858 (108840), 362300 ms
[21:35:05] scan: chap 16 c=16->16, b=1970859->2017406 (46548), 340700 ms
[21:35:05] scan: chap 17 c=17->17, b=2017407->2017495 (89), 500 ms
[21:35:05] scan: aspect = 1.77778
[21:35:05] scan: decoding previews for title 22
libdvdnav: DVD disk reports itself with Region mask 0x00c00000. Regions: 1 2 3 4 5 6
[21:35:05] scan: title angle(s) 1
[21:35:05] scan: audio 0x80bd: AC-3, rate=48000Hz, bitrate=448000 English (AC3) (5.1 ch)
[21:35:05] scan: 10 previews, 720x480, 23.976 fps, autocrop = 60/66/6/4, aspect 16:9, PAR 32:27
[21:35:05] libhb: scan thread found 1 valid title(s)
[21:35:06] 1 job(s) to process
[21:35:06] starting job
[21:35:06] work: track 1, dithering not supported by codec
[21:35:06] sync: expecting 154282 video frames
[21:35:06] job configuration:
[21:35:06] * source
[21:35:06] + M:\DVDS\xxxxxxxxxx.ISO
[21:35:06] + title 22, chapter(s) 1 to 17
[21:35:06] * destination
[21:35:06] + M:\OutputFolder\MP4\xxxxxxx.mp4
[21:35:06] + container: MPEG-4 (mp4v2)
[21:35:06] * video track
[21:35:06] + decoder: mpeg2
[21:35:06] + bitrate 9800 kbps
[21:35:06] + filters
[21:35:06] + Framerate Shaper (0:27000000:1126125)
[21:35:06] + frame rate: same as source (around 23.976 fps)
[21:35:06] + Crop and Scale (710:354:60:66:6:4)
[21:35:06] + source: 720 * 480, crop (60/66/6/4): 710 * 354, scale: 710 * 354
[21:35:06] + loose anamorphic
[21:35:06] + storage dimensions: 710 * 354, mod 2
[21:35:06] + pixel aspect ratio: 32 / 27
[21:35:06] + display dimensions: 841 * 354
[21:35:06] + encoder: H.264 (x264)
[21:35:06] + x264 preset: veryfast
[21:35:06] + h264 profile: main
[21:35:06] + h264 level: 4.0
[21:35:06] + quality: 0.00 (RF)
[21:35:06] * audio track 1
[21:35:06] + decoder: English (AC3) (5.1 ch) (track 1, id 0x80bd)
[21:35:06] + bitrate: 448 kbps, samplerate: 48000 Hz
[21:35:06] + mixdown: Dolby Pro Logic II
[21:35:06] + encoder: AAC (avcodec)
[21:35:06] + bitrate: 160 kbps, samplerate: 48000 Hz
libdvdnav: Using dvdnav version 4.1.3
libdvdread: Encrypted DVD support unavailable.
libdvdnav: DVD Title: xxxxxxxxxx
libdvdnav: DVD Serial Number: xxxxxxxxxxx
libdvdnav: DVD Title (Alternative):
libdvdnav: Unable to find home directorylibdvdnav: DVD disk reports itself with Region mask 0x00c00000. Regions: 1 2 3 4 5 6
libdvdread: Encrypted DVD support unavailable.
libdvdnav: DVD disk reports itself with Region mask 0x00c00000. Regions: 1 2 3 4 5 6
[21:35:06] reader: first SCR 146 id 0xe0 DTS 22254
[21:35:06] mpeg2: "Chapter 1" (1) at frame 0 time 3003
[21:35:06] encx264: min-keyint: 24, keyint: 240
[21:35:06] encx264: encoding with stored aspect 32/27
[21:35:06] encx264: Encoding at constant RF 0.000000
[21:35:06] hb_apply_h264_profile [warning]: lossless requires high444 profile, disabling
x264 [warning]: --psnr used with psy on: results will be invalid!
x264 [warning]: --tune psnr should be used if attempting to benchmark psnr!
x264 [info]: using SAR=32/27
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.1 Cache64
x264 [info]: profile Main, level 4.0
[21:35:06] sync: first pts is 3003
[21:36:02] mpeg2: "Chapter 2" (2) at frame 9189 time 34495461
[21:36:38] work: average encoding speed for job is 156.695526 fps
[21:36:40] sync: got 14536 frames, 154282 expected
[21:36:40] render: lost time: 0 (0 frames)
[21:36:40] render: gained time: 0 (0 frames) (0 not accounted for)
[21:36:40] reader: done. 1 scr changes
[21:36:40] mpeg2 done: 14554 frames
x264 [info]: frame I:132 Avg QP: 0.82 size:124813 PSNR Mean Y:61.89 U:62.40 V:62.73 Avg:62.03 Global:61.17
x264 [info]: frame P:6844 Avg QP: 2.72 size:100273 PSNR Mean Y:56.70 U:57.40 V:57.68 Avg:56.83 Global:56.22
x264 [info]: frame B:7516 Avg QP: 4.84 size: 62136 PSNR Mean Y:54.93 U:56.26 V:56.74 Avg:55.10 Global:53.83
x264 [info]: consecutive B-frames: 15.1% 41.1% 18.3% 25.5%
x264 [info]: mb I I16..4: 20.5% 0.0% 79.5%
x264 [info]: mb P I16..4: 14.3% 0.0% 11.4% P16..4: 26.2% 21.5% 23.2% 0.0% 0.0% skip: 3.4%
x264 [info]: mb B I16..4: 5.6% 0.0% 2.0% B16..8: 22.1% 25.1% 13.8% direct:23.9% skip: 7.5% L0:28.5% L1:31.0% BI:40.6%
x264 [info]: coded y,uvDC,uvAC intra: 96.1% 97.5% 97.5% inter: 90.1% 82.8% 80.8%
x264 [info]: i16 v,h,dc,p: 20% 10% 53% 17%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 32% 17% 22% 5% 5% 6% 4% 5% 5%
x264 [info]: i8c dc,h,v,p: 64% 12% 19% 6%
x264 [info]: Weighted P-Frames: Y:5.2% UV:2.4%
x264 [info]: SSIM Mean Y:0.9983003 (27.696db)
x264 [info]: PSNR Mean Y:55.822 U:56.852 V:57.233 Avg:55.971 Global:54.831 kb/s:15482.24
[21:36:40] mux: track 0, 14367 frames, 1159476907 bytes, 15479.72 kbps, fifo 1024
[21:36:40] mux: track 1, 28087 frames, 11996370 bytes, 160.16 kbps, fifo 2048
[21:36:40] libhb: work result = 0

Encoding stopped

Coordinator
Jul 4, 2013 at 5:23 AM
Looks like you've set the quality level to RF 0 (lossless). Change that back to 20 and you'll start seeing reasonable sizes again.
Jul 4, 2013 at 5:29 AM
Edited Jul 4, 2013 at 5:29 AM
All settings are at default though. Ive experimented with setting the quality level to max before, but it hadnt made the sizes as big as they are previously.

Ive uninstalled it and reinstalled it and reset the settings but its still doing the massive files for some reason.

Heres a screenshot of the settings how I have them. Everything is default/normal.
http://postimg.org/image/jerc8xdgt/
Jul 4, 2013 at 5:44 AM
I think the constant quality slider is bugged for me? If I choose avg bitrate/target options they work ok for me and output the correct bitrate and size. For some reason no matter what I pick on the slider with constant, its setting the bitrate really high to 9800kbps
Coordinator
Jul 4, 2013 at 8:53 AM
That's odd; I can't seem to reproduce that issue. Do you get the problem in 1.4.22 as well?
Jul 4, 2013 at 7:34 PM
Yes both the x64 beta and the 1.4.22 releases did this. It started happening after I had a long queue of isos to convert. One of them had an error and every video I try to convert afterwards has the size issue
Coordinator
Jul 5, 2013 at 8:53 AM
Try going to %appdata%\VidCoder and renaming VidCoder.sqlite . Since you said something happened I wonder if your settings got corrupted somehow.
Jul 10, 2013 at 9:33 PM
I noticed the same problem with my install, but I am doing MKVs. I am using windows 8 x64 and just did the sqlite trick. Testing right now will report back.
Jul 11, 2013 at 12:11 AM
Same :( Converting a BD thats 21GB makes an mkv thats 21GB. The difference between the two is that the BD has two audio tracks, when converting I only select one. Not sure how Vidcoder handles DTS-MA but it was fine in Version 1.4.17-Beta portable. Normally I was getting conversions at half or less than what the BD folder was. Renaming the SQLite file didnt do much.
Coordinator
Jul 11, 2013 at 12:54 AM
Well you can use 1.4.22 until I sort this out. I'll double-check the structs and see if there's anything that might cause it to receive 0 for the RF, and think a bit more about this.
Jul 11, 2013 at 1:15 AM
RandomEngy wrote:
Try going to %appdata%\VidCoder and renaming VidCoder.sqlite . Since you said something happened I wonder if your settings got corrupted somehow.
Doing this worked for me
Coordinator
Jul 11, 2013 at 1:48 AM
channelx99: Could you send me your old, busted VidCoder.sqlite file and let me know which preset you were using? Might be able to find out what happened to it.

Elitoh7: Since renaming the sqlite file didn't help with you, maybe you have a different problem. Can you post an encode log?
Jul 11, 2013 at 5:34 AM
Does Vidcoder have the newest Handbrake core for download? v 9.91 is the appellation. I prefer Vidcoder and it's screen layout. I'm presuming the same functionality.
Coordinator
Jul 11, 2013 at 6:06 AM
I don't know of any HandBrake version 9.91. VidCoder 1.4.22 is based off of HandBrake 0.9.9.
Jul 11, 2013 at 9:11 AM
@RandomEngy

I would love to send you both from version 1.4.22 and version 1.4.17 portable but it is limiting me in the amount of characters. Each log exceeds the 10000 character limit :) At any rate using 1.4.22 file size was 21.6GB, with 1.4.17 it was 15.6GB using same settings for both. Both were set to constant quality 19, audio is passthrough DTS-MA in both cases. So I guess for now I will continue to use 1.4.17.....

Another thing I noticed is with the subtitles, I select "Foreign Audio Search", "Forced only". When I did this in the past it would always show the forced subtitles and for some reason it doesn't now I have to select "Burn In" for it to show the Forced Only subs. Obviously not a huge deal but just throwing it out there to see which is the correct method of showing "Forced Only" subs. Thanks
Coordinator
Jul 11, 2013 at 4:04 PM
Use Pastebin for the logs.

As for the subtitles, Forced Only means that it will choose a narrower set of subtitles: it will only pick the ones that are "forced". Burn in means that it will write those subtitles onto the picture. If you have subtitles on a video that are not burned in, you might have to go pick them in the video player for them to show up. If this is different from what you're seeing, again logs would help here.
Jul 11, 2013 at 10:28 PM
@RandomEngy Here are the logs

Log 1 with 1.4.22
http://pastebin.com/JcDz01u4

Log 2 with 1.4.17
http://pastebin.com/gUef7g9q
Coordinator
Jul 11, 2013 at 10:56 PM
You were having the size issue with 1.4.22 but not with 1.4.17?
Jul 11, 2013 at 10:58 PM
That is correct. I have since gone back to using 1.4.17 Portable to do conversion and everything seems to be working fine. Doing a couple more tonight I will post my findings.
Coordinator
Jul 11, 2013 at 11:04 PM
Hmm well in 1.4.22 you've picked two copies of the DTS-HD MA track, while in 1.4.17 you were picking two copies of the regular DTS track, which is much smaller. I would suggest removing one of the audio encodings and picking the DTS track instead (or compressing the audio).
Jul 11, 2013 at 11:13 PM
Not sure what is up there but I selected only the dts-ma track. In the settings for the profile, I have it set to do auto pass on audio tracks 1 and 2. Reason for that is that I would pick DTS(or DTS-MA) and Dolby Digital(or True-HD) depending on the movie. If the movie only had DTS or DTS-MA I would pick DTS-MA. In both I selected the DTS-MA track and only that one. I noticed that it said I selected both. I wonder if its broke in 1.4.17? Meaning even though I select DTS-MA it defaults to DTS, I don't know.. I am running a few more conversions and I know I selected the DTS-MA track so we'll see what happens and then I'll do that one again to verify your feedback.
Coordinator
Jul 12, 2013 at 5:22 PM
Can you export and share the preset you're using? I want to get a good idea of how it's picking the audio tracks that would cause it to duplicate.
Jul 12, 2013 at 6:06 PM
Heres the preset:

<?xml version="1.0" encoding="utf-8"?>
<UserPreset Version="8">
<Preset xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<Name>High Profile MKV</Name>
<IsBuiltIn>false</IsBuiltIn>
<IsModified>false</IsModified>
<IsQueue>false</IsQueue>
<EncodingProfile>
  <OutputFormat>Mkv</OutputFormat>
  <PreferredExtension>Mp4</PreferredExtension>
  <IncludeChapterMarkers>true</IncludeChapterMarkers>
  <LargeFile>true</LargeFile>
  <Optimize>false</Optimize>
  <IPod5GSupport>false</IPod5GSupport>
  <Width>0</Width>
  <Height>0</Height>
  <MaxWidth>0</MaxWidth>
  <MaxHeight>0</MaxHeight>
  <CustomCropping>false</CustomCropping>
  <CroppingType>None</CroppingType>
  <Cropping>
    <Top>0</Top>
    <Bottom>0</Bottom>
    <Left>0</Left>
    <Right>0</Right>
  </Cropping>
  <Anamorphic>Loose</Anamorphic>
  <UseDisplayWidth>false</UseDisplayWidth>
  <DisplayWidth>0</DisplayWidth>
  <KeepDisplayAspect>true</KeepDisplayAspect>
  <PixelAspectX>0</PixelAspectX>
  <PixelAspectY>0</PixelAspectY>
  <Modulus>2</Modulus>
  <Deinterlace>Off</Deinterlace>
  <Decomb>Default</Decomb>
  <Detelecine>Off</Detelecine>
  <Denoise>Off</Denoise>
  <Deblock>0</Deblock>
  <Grayscale>false</Grayscale>
  <VideoEncoder>x264</VideoEncoder>
  <X264Options />
  <X264Profile>high</X264Profile>
  <X264Preset>medium</X264Preset>
  <X264Tunes />
  <H264Level>4.1</H264Level>
  <VideoEncodeRateType>ConstantQuality</VideoEncodeRateType>
  <Quality>19</Quality>
  <TargetSize>0</TargetSize>
  <VideoBitrate>0</VideoBitrate>
  <TwoPass>false</TwoPass>
  <TurboFirstPass>false</TurboFirstPass>
  <Framerate>0</Framerate>
  <ConstantFramerate>false</ConstantFramerate>
  <AudioEncodings>
    <AudioEncoding>
      <InputNumber>0</InputNumber>
      <Encoder>copy</Encoder>
      <EncodeRateType>Bitrate</EncodeRateType>
      <Bitrate>0</Bitrate>
      <Quality>0</Quality>
      <Compression>-1</Compression>
      <SampleRateRaw>0</SampleRateRaw>
      <Gain>0</Gain>
      <Drc>0</Drc>
    </AudioEncoding>
    <AudioEncoding>
      <InputNumber>0</InputNumber>
      <Encoder>copy</Encoder>
      <EncodeRateType>Bitrate</EncodeRateType>
      <Bitrate>0</Bitrate>
      <Quality>0</Quality>
      <Compression>-1</Compression>
      <SampleRateRaw>0</SampleRateRaw>
      <Gain>0</Gain>
      <Drc>0</Drc>
    </AudioEncoding>
  </AudioEncodings>
</EncodingProfile>
</Preset>
</UserPreset>

Heres an xml of one of the movies:

<?xml version="1.0" encoding="UTF-8"?>
<Mediainfo version="0.7.64">
<File>
<track type="General">
<Unique_ID>291778578240292783608676303086977925127 (0xDB828295AD00E5816CDEBF9228B1C007)</Unique_ID>
<Complete_name>D:.....Down.mkv</Complete_name>
<Format>Matroska</Format>
<Format_version>Version 2</Format_version>
<File_size>9.51 GiB</File_size>
<Duration>1h 57mn</Duration>
<Overall_bit_rate_mode>Variable</Overall_bit_rate_mode>
<Overall_bit_rate>11.6 Mbps</Overall_bit_rate>
<Writing_application>HandBrake 5358svn</Writing_application>
<Writing_library>libmkv 0.6.5</Writing_library>
</track>

<track type="Video">
<ID>1</ID>
<Format>AVC</Format>
<Format_Info>Advanced Video Codec</Format_Info>
<Format_profile>High@L4.1</Format_profile> <Format_settings__CABAC>Yes</Format_settings__CABAC> <Format_settings__ReFrames>4 frames</Format_settings__ReFrames>
<Codec_ID>V_MPEG4/ISO/AVC</Codec_ID>
<Width>1 920 pixels</Width>
<Height>1 080 pixels</Height>
<Display_aspect_ratio>16:9</Display_aspect_ratio>
<Frame_rate_mode>Variable</Frame_rate_mode>
<Color_space>YUV</Color_space>
<Chroma_subsampling>4:2:0</Chroma_subsampling>
<Bit_depth>8 bits</Bit_depth>
<Scan_type>Progressive</Scan_type>
<Writing_library>x264 core 130</Writing_library>
<Encoding_settings>cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=6 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=240 / keyint_min=24 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=crf / mbtree=1 / crf=19.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / vbv_maxrate=62500 / vbv_bufsize=78125 / crf_max=0.0 / nal_hrd=none / ip_ratio=1.40 / aq=1:1.00</Encoding_settings>
<Language>English</Language>
<Default>Yes</Default>
<Forced>No</Forced>
<Color_primaries>BT.709</Color_primaries>
<Transfer_characteristics>BT.709</Transfer_characteristics>
<Matrix_coefficients>BT.709</Matrix_coefficients>
</track>

<track type="Audio" streamid="1">
<ID>2</ID>
<Format>DTS</Format>
<Format_Info>Digital Theater Systems</Format_Info>
<Format_profile>MA / Core</Format_profile>
<Mode>16</Mode>
<Format_settings__Endianness>Big</Format_settings__Endianness>
<Codec_ID>A_DTS</Codec_ID>
<Duration>1h 57mn</Duration>
<Bit_rate_mode>Variable</Bit_rate_mode>
<Bit_rate>Unknown / 1 509 Kbps</Bit_rate>
<Channel_s_>6 channels</Channel_s_>
<Channel_positions>Front: L C R, Side: L R, LFE</Channel_positions>
<Sampling_rate>48.0 KHz</Sampling_rate>
<Bit_depth>24 bits</Bit_depth>
<Compression_mode>Lossless / Lossy</Compression_mode>
<Language>English</Language>
<Default>Yes</Default>
<Forced>No</Forced>
</track>

<track type="Audio" streamid="2">
<ID>3</ID>
<Format>DTS</Format>
<Format_Info>Digital Theater Systems</Format_Info>
<Format_profile>MA / Core</Format_profile>
<Mode>16</Mode>
<Format_settings__Endianness>Big</Format_settings__Endianness>
<Codec_ID>A_DTS</Codec_ID>
<Duration>1h 57mn</Duration>
<Bit_rate_mode>Variable</Bit_rate_mode>
<Bit_rate>Unknown / 1 509 Kbps</Bit_rate>
<Channel_s_>6 channels</Channel_s_>
<Channel_positions>Front: L C R, Side: L R, LFE</Channel_positions>
<Sampling_rate>48.0 KHz</Sampling_rate>
<Bit_depth>24 bits</Bit_depth>
<Compression_mode>Lossless / Lossy</Compression_mode>
<Language>English</Language>
<Default>No</Default>
<Forced>No</Forced>
</track>

<track type="Menu">
<_00_00_00000>Chapter 1</_00_00_00000>
<_00_11_40967>Chapter 2</_00_11_40967>
<_00_16_48608>Chapter 3</_00_16_48608>
<_00_25_18367>Chapter 4</_00_25_18367>
<_00_30_38646>Chapter 5</_00_30_38646>
<_00_36_37796>Chapter 6</_00_36_37796>
<_00_41_19828>Chapter 7</_00_41_19828>
<_00_46_36686>Chapter 8</_00_46_36686>
<_00_55_52533>Chapter 9</_00_55_52533>
<_01_03_13223>Chapter 10</_01_03_13223>
<_01_12_09050>Chapter 11</_01_12_09050>
<_01_18_25051>Chapter 12</_01_18_25051>
<_01_24_07059>Chapter 13</_01_24_07059>
<_01_31_35590>Chapter 14</_01_31_35590>
<_01_36_36182>Chapter 15</_01_36_36182>
<_01_42_52433>Chapter 16</_01_42_52433>
</track>

</File>
</Mediainfo>


And finally here is an image of the completed conversion's with only one track selected.

Image
Coordinator
Jul 12, 2013 at 6:10 PM
You have two encodings for audio which are both Auto Passthrough and targeting All Streams. That's why you're getting two copies of each track.
Jul 12, 2013 at 6:25 PM
So even though only one track is selected in the main window it still wants to do two? So heres something else that is interesting, as you can see in the image I have dts-ma selected and it still only came across as DTS, with two tracks that are both DTS. I checked with my BD Player and it says DTS, not DTS-MA. I will have at it again with the new version. I am going to remove everything that has to do vidcoder and try again. Also the latest conversions are with 1.4.17, so there must have been something wrong with that one.
Coordinator
Jul 12, 2013 at 6:29 PM
Yes, if you have two encodings and one input track, it will write out two tracks.

And I don't see any image there. Though it's possible your player lists both DTS and DTS-MA as "DTS".
Jul 12, 2013 at 8:24 PM
Here is a link to the image.

http://tinypic.com/view.php?pic=2ywil45&s=5

As for the Player I have tried, VLC, my RaspberryPi with openelec and my Oppo Bdp-95... all just say DTS other streams might say DTS-MA or DTS 6.1... But let me check what my Receiver says its getting. I'll be back.
Jul 12, 2013 at 8:37 PM
Ok, so all maybe ok... On the file that I gave you the xml's for my Receiver does pick up DTS-MA but it does have 2 tracks even thought I only selected one. Do you think that's because of the profile I created? I recently uninstalled and made sure all of the Vidcoder files were gone. Reinstalled 1.4.22x64 and running a convert, but as you saw it takes about 3 hours per... If its doubling up the audio that could explain why the files are so big.. I'll check that file with mkvmergegui and see if I can remove one of the audio tracks.
Coordinator
Jul 12, 2013 at 8:43 PM
Yes I already said it's giving you two tracks because your profile is set up to duplicate the track you chose. Remove one of the audio encodings in it:

Image
Jul 12, 2013 at 8:54 PM
I was a bit confused about that, what I was trying to accomplish was to auto select the two streams which is what I thought it was doing because on the main screen it was selecting the different tracks. But I guess being lazy doesn't always pay off ;) . I did check the file that I had with mkvmerge and it was doing two tracks even though on the main screen it only had the one track selected. So easily enough I will be able to remove that and see if the size goes down(which it should)