1.5.23 beta burnin subtitles no all serbian, croatian characters (ISO - 8859 -2)

Jul 15, 2014 at 12:38 PM
Edited Jul 15, 2014 at 12:50 PM
Hi,
I think that VidCoder is great tool, for all of us who want to implement (hardcode) subtitles
into mkv file, and later watch movies on TV(by USB).
When I burn in subtitle in mkv file, after process is finished I noticed that some characters is missing in ISO - 8859 -2 code (this encoding system support central/east european latin characters). Actually letter Ž, ž is missing and letter Š š I think that is not fit with all others fonts here.All others specific characters is OK (I mean Đ, Ć, Č, đ,ć,č)
Image
I don't know if you see screenshot of sample.
Here stand: "Ali glad moemo lako utiŠati, lako zasititi"
actually in srt file correctly stand: "Ali glad možemo lako utišati, lako zasititi"
I want to know any chance to be fixed.
Coordinator
Jul 15, 2014 at 2:45 PM
To clarify: You've saved the .SRT file in ISO-8859-2 format, and specified ISO-8859-2 as the Char code for the SRT in VidCoder?

If that's not working, could you try saving the SRT file as UTF-8 and specifying that char code in the Subtitles window?
Jul 15, 2014 at 3:24 PM
Edited Jul 15, 2014 at 3:25 PM
I download subtitle from http://rs.titlovi.com/ and after unziping I gave regulary .srt file
which is encoded in croatian by some guys who translate this episode in croatian. I am not expert but I don' know did this .srt file is encoded in ISO-8859-2 format or not.
For example when I run mkv file The.Strain.S01E01.720p.HDTV.X264-DIMENSION along with same name .srt file in my PC (The KM player), I receive normally encoded subtitle according my previous set up in this player, but when I same .srt file converting with mkv file The.Strain.S01E01.720p.HDTV.X264-DIMENSION by VidCoder
I gave effect what I attached in my first post.
I don't know did I clarify anything, but I think that is VidCoder will be awesome for me if I be able to give all characters in serbian/croatian. I noted characters Ž, ž that at all not appear and letter Š, š is not fit as all others fonts in ISO-8859-2
I hope you will help me.
Thanks in advance
Image
Coordinator
Jul 15, 2014 at 4:08 PM
Well you need the format of the file and the Char Code in VidCoder to match up. Just because ISO-8859-2 supports certain characters does not mean that choosing that format will work correctly for the file! I would try opening the SRT file with a program like Notepad2 and saving it with UTF-8, then choosing UTF-8 in VidCoder. UTF-8 also supports all characters in unicode.
Jul 15, 2014 at 4:21 PM
Yes, mate. You are right. I just do 15% converting mkv+srt(saved in UTF-8 by Notepad) and worked fine. That is what I want.
Any chance to conver time be little bit short.
Fot this episode The.Strain.S01E01.720p.HDTV.X264-DIMENSION.mkv duration is 69:55 min, size: 1.6 GB elapsed time is 80 minutes.
I want to stay on similar quality as on original mkv file 1280x720, but not neccesserly.
How I speed up conversion.
Thanks again for subtitle problem.
Coordinator
Jul 15, 2014 at 5:52 PM
There are a few good ways to make conversion faster:

1) Avoid 2-pass encoding and use Constant Quality instead
2) Avoid changing the video size to avoid a rescale filter
3) Use Intel QSV encoding if it's supported
4) Use a faster x264 preset to trade compression efficiency for encode speed
Jul 16, 2014 at 4:57 PM
OMG, now is exist new problem.
I successfully convert video with subtitles.
I run this episode on my TV, but after 6:40 mins video is ejected, just after
intertitle is finished. You know, before starting new scene (chapter), after fade away.
I don't know exact expression in english.
Maybe problem is because I preset Encoder Settings at UltraFast or Constant Quality: 23?
Image
Any tips?
Coordinator
Jul 16, 2014 at 5:03 PM
I don't know what you mean by "Ejected". But the preset or quality targets should not cause a video to stop short.