This project is read-only.
1
Vote

Encode failed

description

A file in a batch of encodes just failed, the rest are still being processed. Here is the log for the failed file.
# Starting job 6/12
#   Path: G:\2013-01-11.Prt1.mpg
#   Title: 1
#   Range: All
# Worker ready: Service state is Opened on pipe VidCoderWorker
# Connecting to process 4308
[00:08:09] hb_init: starting libhb thread
[00:08:09] hb_scan: path=G:\2013-01-11.Prt1.mpg, title_index=1
libbluray/bdnav/index_parse.c:162: indx_parse(): error opening G:\2013-01-11.Prt1.mpg/BDMV/index.bdmv
libbluray/bdnav/index_parse.c:162: indx_parse(): error opening G:\2013-01-11.Prt1.mpg/BDMV/BACKUP/index.bdmv
libbluray/bluray.c:1725: nav_get_title_list(G:\2013-01-11.Prt1.mpg) failed (038FD7D0)
[00:08:09] bd: not a bd - trying as a stream/file instead
libdvdread: Encrypted DVD support unavailable.
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
dvd: ifoOpen failed
[00:08:09] file is MPEG Program Stream
[00:08:09] Probing 1 unknown stream
[00:08:09]     Probe: Found stream mpeg2video. stream id 0xe0-0x0
[00:08:09] Found the following streams
[00:08:09]     Video Streams : 
[00:08:09]       0xe0-0x0 type MPEG2 (0x2)
[00:08:09]     Audio Streams : 
[00:08:09]       0xc0-0x0 type MPEG2 (0x4)
[00:08:09]     Subtitle Streams : 
[00:08:09]     Other Streams : 
[00:08:09] stream id 0xc0 (type 0x4 substream 0x0) audio 0xc0
[00:08:10] scan: decoding previews for title 1
[00:08:10] scan: audio 0xc0: mp2, rate=48000Hz, bitrate=192000 Unknown (MPEG2) (2.0 ch)
[00:08:10] scan: 10 previews, 704x576, 25.000 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 16:11
[00:08:10] stream: 34 good frames, 0 errors (0%)
[00:08:10] libhb: scan thread found 1 valid title(s)
[00:08:10] 1 job(s) to process
[00:08:10] starting job
[00:08:10] yadif thread started for segment 0
[00:08:10] yadif thread started for segment 1
[00:08:10] yadif thread started for segment 2
[00:08:10] yadif thread started for segment 3
[00:08:10] yadif thread started for segment 4
[00:08:10] yadif thread started for segment 5
[00:08:10] decomb filter thread started for segment 0
[00:08:10] decomb filter thread started for segment 1
[00:08:10] decomb filter thread started for segment 2
[00:08:10] decomb filter thread started for segment 3
[00:08:10] decomb filter thread started for segment 4
[00:08:10] decomb filter thread started for segment 5
[00:08:10] decomb check thread started for segment 0
[00:08:10] decomb check thread started for segment 1
[00:08:10] decomb check thread started for segment 2
[00:08:10] decomb check thread started for segment 3
[00:08:10] decomb check thread started for segment 4
[00:08:10] decomb check thread started for segment 5
[00:08:10] mask filter thread started for segment 0
[00:08:10] mask filter thread started for segment 1
[00:08:10] mask filter thread started for segment 2
[00:08:10] mask filter thread started for segment 3
[00:08:10] mask filter thread started for segment 4
[00:08:10] mask filter thread started for segment 5
[00:08:10] mask erode thread started for segment 0
[00:08:10] mask erode thread started for segment 1
[00:08:10] mask erode thread started for segment 2
[00:08:10] mask erode thread started for segment 3
[00:08:10] mask erode thread started for segment 4
[00:08:10] mask erode thread started for segment 5
[00:08:10] mask dilate thread started for segment 0
[00:08:10] mask dilate thread started for segment 1
[00:08:10] mask dilate thread started for segment 2
[00:08:10] mask dilate thread started for segment 3
[00:08:10] mask dilate thread started for segment 4
[00:08:10] mask dilate thread started for segment 5
[00:08:10] work: sanitizing track 1 mixdown Dolby Pro Logic II to Stereo
[00:08:10] work: track 1, compression level not supported by codec
[00:08:10] work: track 1, quality mode not supported by codec
[00:08:10] work: track 1, dithering not supported by codec
[00:08:10] sync: expecting 32880 video frames
[00:08:10] job configuration:
[00:08:10]  * source
[00:08:10]    + G:\2013-01-11.Prt1.mpg
[00:08:10]    + title 1, chapter(s) 1 to 1
[00:08:10]  * destination
[00:08:10]    + G:\Soaps\Encoded\CoronationStreet.2013-01-11.Prt1-1.mp4
[00:08:10]    + container: MPEG-4 (.mp4 and .m4v)
[00:08:10]  * video track
[00:08:10]    + decoder: mpeg2
[00:08:10]      + bitrate 15000 kbps
[00:08:10]    + frame rate: 25.000 fps -> constant 25.000 fps
[00:08:10]    + filters
[00:08:10]      + Decomb (default settings)
[00:08:10]      + Framerate Shaper (1:27000000:1080000)
[00:08:10]        + frame rate: 25.000 fps -> constant 25.000 fps
[00:08:10]      + Crop and Scale (1024:576:2:0:0:0)
[00:08:10]        + source: 704 * 576, crop (2/0/0/0): 704 * 574, scale: 1024 * 576
[00:08:10]    + dimensions: 1024 * 576, mod 0
[00:08:10]    + encoder: H.264 (x264)
[00:08:10]      + x264 preset: slow
[00:08:10]      + options: qpmin=0
[00:08:10]      + quality: 24.00 (RF)
[00:08:10]  * audio track 1
[00:08:10]    + decoder: Unknown (MPEG2) (2.0 ch) (track 2, id 0xc0)
[00:08:10]      + bitrate: 192 kbps, samplerate: 48000 Hz
[00:08:10]    + mixdown: Stereo
[00:08:10]    + encoder: AAC (faac)
[00:08:10]      + bitrate: 112 kbps, samplerate: 48000 Hz
[00:08:10] file is MPEG Program Stream
[00:08:10] Probing 1 unknown stream
[00:08:10]     Probe: Found stream mpeg2video. stream id 0xe0-0x0
[00:08:10] reader: first SCR 194 id 0xe0 DTS 18000
[00:08:10] encx264: Encoding at constant RF 24.000000
x264 [warning]: --psnr used with psy on: results will be invalid!
x264 [warning]: --tune psnr should be used if attempting to benchmark psnr!
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSEMisalign LZCNT
[00:08:10] mpeg2: "Chapter 1" (1) at frame 0 time 3600
x264 [info]: profile High, level 3.1
[00:08:10] sync: first pts is 3600
[00:11:08] mpeg2 tag botch: pts 31633200, tag pts 31615200 buf 00000000
[00:11:08] sync: video time didn't advance - dropped 1 frames (delta 0 ms, current 31608000, next 31615200, dur 7200)
# Worker process exited unexpectedly; no additional details are available. This may be due to a HandBrake engine crash.
# Encode failed.
# Job completed

comments

RandomEngy wrote Mar 12, 2013 at 4:58 AM

The log seems to indicate that the HandBrake encoding core crashed. Does it crash consistently? Have you tried it in the latest HandBrake nightly?

Croftie wrote Mar 12, 2013 at 6:20 AM

No it doesn't, I added the same file after the queue finished and it encoded successfully. The file encoded fine in handbrake too although it wouldn't allow me to set the resolution the same because it doesn't allow higher than source. Apart from that the settings were identical.

RandomEngy wrote Mar 12, 2013 at 7:06 AM

Probably a non-deterministic crash in the HandBrake core. I can't really do much about that one.

Croftie wrote Mar 12, 2013 at 8:19 AM

Seems like the way forward is to switch to handbrake untill I get a failed encode then report it to them?

RandomEngy wrote Mar 12, 2013 at 4:53 PM

Yeah I suppose so. These are the most annoying crashes.