1

Closed

crash after dragging movie on vidcoder window

description

1540
First dragging worked, but after I reverted my preset, vidcoder crashed. After that, dragging a movie on vidcoder window causes a crash.
System.NullReferenceException: Object reference not set to an instance of an object.
   at HandBrake.Interop.Model.Encoders.GetDefaultMixdown(HBAudioEncoder encoder, UInt64 layout) in d:\docs\projects\HandBrakeSVN\win\CS\HandBrake.Interop\HandBrakeInterop\Model\Encoders.cs:line 0
   at VidCoder.ViewModel.AudioPanelViewModel.GetAudioPreview(AudioTrack inputTrack, AudioEncodingViewModel audioVM) in d:\docs\projects\VidCoder\VidCoder\ViewModel\Panels\AudioPanelViewModel.cs:line 313
   at VidCoder.ViewModel.AudioPanelViewModel.RefreshAudioPreview() in d:\docs\projects\VidCoder\VidCoder\ViewModel\Panels\AudioPanelViewModel.cs:line 211
   at VidCoder.ViewModel.AudioPanelViewModel.NotifyAudioInputChanged() in d:\docs\projects\VidCoder\VidCoder\ViewModel\Panels\AudioPanelViewModel.cs:line 425
   at VidCoder.ViewModel.AudioPanelViewModel.<.ctor>b__0(AudioInputChangedMessage message) in d:\docs\projects\VidCoder\VidCoder\ViewModel\Panels\AudioPanelViewModel.cs:line 44
   at GalaSoft.MvvmLight.Helpers.WeakAction`1.Execute(T parameter)
   at GalaSoft.MvvmLight.Helpers.WeakAction`1.ExecuteWithObject(Object parameter)
   at GalaSoft.MvvmLight.Messaging.Messenger.SendToList[TMessage](TMessage message, IEnumerable`1 list, Type messageTargetType, Object token)
   at GalaSoft.MvvmLight.Messaging.Messenger.SendToTargetOrType[TMessage](TMessage message, Type messageTargetType, Object token)
   at GalaSoft.MvvmLight.Messaging.Messenger.Send[TMessage](TMessage message)
   at VidCoder.ViewModel.MainViewModel.<.ctor>b__4(Object o, NotifyCollectionChangedEventArgs e) in d:\docs\projects\VidCoder\VidCoder\ViewModel\MainViewModel.cs:line 122
   at System.Collections.Specialized.NotifyCollectionChangedEventHandler.Invoke(Object sender, NotifyCollectionChangedEventArgs e)
   at System.Collections.ObjectModel.ObservableCollection`1.OnCollectionChanged(NotifyCollectionChangedEventArgs e)
   at System.Collections.ObjectModel.ObservableCollection`1.InsertItem(Int32 index, T item)
   at System.Collections.ObjectModel.Collection`1.Add(T item)
   at VidCoder.ViewModel.MainViewModel.set_SelectedTitle(Title value) in d:\docs\projects\VidCoder\VidCoder\ViewModel\MainViewModel.cs:line 803
   at VidCoder.ViewModel.MainViewModel.UpdateFromNewVideoSource() in d:\docs\projects\VidCoder\VidCoder\ViewModel\MainViewModel.cs:line 2434
   at VidCoder.ViewModel.MainViewModel.<>c__DisplayClass6b.<StartScan>b__6a() in d:\docs\projects\VidCoder\VidCoder\ViewModel\MainViewModel.cs:line 2387
   at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
   at MS.Internal.Threading.ExceptionFilterHelper.TryCatchWhen(Object source, Delegate method, Object args, Int32 numArgs, Delegate catchHandler)
hope this helps!
cheers
Wammes

file attachments

Closed Aug 23, 2013 at 3:57 AM by RandomEngy
Fixed in 1.5.5 Beta

comments

RandomEngy wrote Aug 3, 2013 at 4:01 PM

Thanks for the report. Can you export that preset and send it to me? Would help me reproduce the problem so I can fix it.

Wammes wrote Aug 3, 2013 at 5:22 PM

I think it was this preset, not sure, sorry... Also included the latest log. Still crashing with custom presets, not with the default ones!

RandomEngy wrote Aug 3, 2013 at 9:54 PM

Thanks for the info. I've got a fix that will be in the next beta. For a workaround, go to the Audio tab and change the Fallback to something else, then switch it back, then save the preset.

Wammes wrote Aug 4, 2013 at 3:58 PM

Allright! Thank you for your work, Vidcoder is just excellent :)