This project is read-only.
1
Vote

Suddenly CPU usage sky high - 1.4.25 (x64)

description

Dear,

Since about 1 week, my machine started crashing. Some investigation learned me that it was due to the process VidCoderWorker.exe which pushed my CPU usage sky high (see attachment), eventually overloading the system.

First time it occured, my machine was working on itself, no manipulations were being made and I did not make any change to my system in the 24 hours before. The system itself is solid, working for months (with same VidCoder version), carrying i7 on Z87 Extreme MB and 8 Gb of memory. So it would seem odd to start running short on system resources.

I tried re-installation of VidCoder 1.4.25 but without positive evolution. I also tried Beta 1.5.25 (x64). On that build it doesn't have the same behvior but then again each conversion also fails after 1é seconds so that doesn't bring a solution either.

Does anyone have an idea what might be happening ? I was thinking about memory leakage somehow but how to verify that ? Are there any logs linked to VidCoder that I could consult in order to get an idea ?

Br,

Kurt

file attachments

comments

RandomEngy wrote Oct 9, 2014 at 7:21 AM

Sounds like you might have cooling issues on your CPU. It's supposed to push CPU to the max to encode as fast as it can.

ChuckQ wrote Oct 9, 2014 at 8:33 AM

I'll take up that suggestion, thx RandomEngy. Now, encoding speed is not of major concern to me, it's running in the background anyway. Could I tweak the amount of CPU resources assigned to the process somehow or is this hardcoded ?

RandomEngy wrote Oct 9, 2014 at 3:31 PM

It's hardcoded. I may add an option someday that allows you to throttle processor use via CPU affinity.