This project is read-only.
1
Vote

VidCoder have experienced an unexpected error

description

Getting this unexpected error when starting VC after making a clean install of VC 2.7 Beta


System.TypeInitializationException: The type initializer for 'VidCoder.Model.Database' threw an exception. ---> System.InvalidOperationException: There is an error in XML document (1, 1). ---> System.Xml.XmlException: Data at the root level is invalid. Line 1, position 1.
at System.Xml.XmlTextReaderImpl.Throw(Exception e)
at System.Xml.XmlTextReaderImpl.Throw(String res, String arg)
at System.Xml.XmlTextReaderImpl.ParseRootLevelWhitespace()
at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
at System.Xml.XmlTextReaderImpl.Read()
at System.Xml.XmlTextReader.Read()
at System.Xml.XmlReader.MoveToContent()
at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderPicker.Read7_Picker()
--- End of inner exception stack trace ---
at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String encodingStyle, XmlDeserializationEvents events)
at VidCoder.Model.PickerStorage.ParsePickerXml(String pickerXml, XmlSerializer serializer) in D:\docs\projects\VidCoder\VidCoder\Model\PickerStorage.cs:line 38
at VidCoder.Model.Database.UpgradeDatabaseTo28() in D:\docs\projects\VidCoder\VidCoder\Model\Database.cs:line 221
at VidCoder.Model.Database..cctor() in D:\docs\projects\VidCoder\VidCoder\Model\Database.cs:line 64
--- End of inner exception stack trace ---
at VidCoder.Model.Database.get_Connection()
at VidCoder.App.OnStartup(StartupEventArgs e) in D:\docs\projects\VidCoder\VidCoder\App.xaml.cs:line 76
at System.Windows.Application.<_ctor>b__0(Object unused)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)

comments

Barough wrote Nov 8, 2015 at 6:36 PM

After 2 more clean re-installs so have the unexpected error disappeared and VC starts as it should.

RandomEngy wrote Nov 13, 2015 at 1:24 AM

Sounds like your VidCoder.sqlite file was corrupted. Was going to ask you for it so I could find the root cause but it sounds like it's gone now.