This project is read-only.
1
Vote

No Disk In Disk Drive Error on load

description

1.0.3.0 (x86)
Upon load, VidCoder immediately reports a "No Disk" error with MsgBox (Abort/Retry/Cancel) on first load after upgrade.

comments

RandomEngy wrote Sep 18, 2011 at 4:56 PM

I don't get this error. Can you get by it? Do you have a floppy drive? Does this happen in 1.0.2?

deltaecho5 wrote Sep 19, 2011 at 12:54 AM

It was just on the first load, on 1.0.3.0 (x86) and called to a D: drive...some things fyi:
-Only dual DVD RAM drives (-No Floppies) D: and
-Both machines running VidCoder got the same error on update (auto update on, VidCoder "reboots" and then errors), both Dual Core Pentiums
-Cancel got by the error
-Closing VidCoder ("X" not "File>Exit") then reloading did not evoke the same error.

Apparently something in past queue or settings that checks the drive on first reboot? Had no files that come from either drive in either machine...all encoded I do are from Hard Drive.

Cheers

RandomEngy wrote Sep 19, 2011 at 6:40 AM

I have two DVD drives as well. Were they empty or did they have discs at the time? Had you queued something from a DVD but since ejected the disc? I'll keep on the lookout for this one.

deltaecho5 wrote Sep 20, 2011 at 2:49 PM

Nothing in the drives...nothing ever queued from the drives (in previous batches or current).
Figured maybe there is a call to the drive by virtue of it existing on the system in the new section of code?

RandomEngy wrote Sep 20, 2011 at 3:49 PM

I did a bit of refactoring in 1.0.2 but I didn't add anything about accessing DVD drives. I'm not really sure why that dialog got triggered.

deltaecho5 wrote Sep 21, 2011 at 3:20 PM

Haven't been able to replicated it either. Posted in the event it was something systemic, and others may have seen it.