This project is read-only.

DTS-HD wont pass through to MKV .. it did in the past

Dec 18, 2012 at 8:18 AM
Edited Dec 18, 2012 at 8:19 AM

As a first time poster, I'd like first to say that VidCoder is a amazing bit of software - thank you!

However, I have a problem with passing through DTS-HD to MKV files and hope you can help.

I am sure that I have successfully passed DTS-HD when encoding BluRays in past, but I'll be damned if I can find how to do it now. This is the approach I am taking:

  1. Scan BluRay
  2. Select Audio Track of "DTS-HD"
  3. In Settings under Audio, I choose Target Stream "Stream 1 DTS HD" and Codec "Auto Passthru"
    (I have also tried all combinations of All Streams and DTS-HD Passthru)
  4. Encode

The result is typically is to encode only one track (plain DTS) - with no other channels/tracks. What happened to my instruction to encode the DTS-HD track only?  It's as if it is downsampling/coding.

If I choose multiple Audio Tracks (one DTS and one DTS-HD), it burns two tracks of DTS. I have also tried several BluRays.

Attached is the log from the latest attempt.

I am using using the latest beta on Win7x64. Your thoughts much appreciated.

Many thanks,

Dec 19, 2012 at 12:44 AM

Well the DTS-HD passthrough is getting properly passed to HandBrake. And it does look like DTS-HD passthrough produces a different and larger file than the DTS passthrough. It seems like it's working to me.

Dec 19, 2012 at 8:45 PM

Thanks for the quick reply Random,

I've run some additional tests where I where I encode both DTS and DTS-HD audio tracks. I then open the created file in VLC Player - under Codec Information ist shows:

1 x Video Stream
1 x Audio DTS
1 x Audio DTS

So, no DTS-HD track, despite the instruction to do so.

Is there another approach?

Dec 19, 2012 at 8:53 PM

Do DTS-HD tracks normally show differently in VLC? What does MediaInfo say? When I check the output file I can see that the stream is bigger and is tagged with "MA" for master.

Dec 19, 2012 at 9:01 PM

I just had a closer look at the the stream information and indeed there is a difference.

Whilst they still show both DTS, one is distinctly different from the other.  Assuming one is DTS-HD, why isn't it being flagged as such?

In earlier attempts (when DTS-HD was being passed correctly), Total Media Theatre would display "DTS-HD" under audio information - it only shows "DTS" for both these tracks (consistent with VLC).

Is it simply a case of mislabeling, or am I not actually getting the HD 'full monty'?

Dec 19, 2012 at 9:29 PM

I'm not familiar with what to look for to confirm if a track really is DTS-HD. If I see this in the log

[18:57:21]  * audio track 1
[18:57:21]    + decoder: English (DTS-HD MA) (5.1 ch) (track 1, id 0x1100)
[18:57:21]      + bitrate: 1536 kbps, samplerate: 48000 Hz
[18:57:21]    + DTS-HD Passthru

I'm reasonably confident that I'm giving the correct directives to the HandBrake core library for it to happen. If this doesn't do the job I would see if you get the same output in HandBrake and if so ask them about it.

Dec 20, 2012 at 8:15 AM

I will try that. Will installing Handbrake (and then presumably unsinstalling it) have any sort of negative effect on my Vidcoder installation?

Dec 20, 2012 at 8:27 AM


Dec 20, 2012 at 8:49 AM

Well, using HB didn't change the outcome, so it appears to be a problem (if it's a problem at all). It might just be a case of it not labelling the track correctly.

Thank you Random for your prompt attention.