This project is read-only.

Unable to find endpoint

Apr 3, 2013 at 7:53 PM
Edited Apr 3, 2013 at 8:53 PM
When I use VidCoder on a Win7 Pro, 64bit computer I always get this when I convert a BluRay to mp4:

.. VidCoder (x64)
. Starting job 1/1
. Path: K:\
. Title: 3
. Range: All
. Worker ready: Service state is Opened on pipe VidCoderWorker
. Connecting to process 1348
. Connection to worker failed after 10 retries. Unable to find endpoint.
. Encode failed.
. Job completed

When I exit VidCoder the VidCoderWorker process is still running.

Any ideas what this can be or what I do wrong?

By the way: If I use Handbrake it works like a charm. But I definitely prefer the VidCoder GUI.

Thanks for your help!
Apr 13, 2013 at 6:50 PM
Thanks for the report. I've done a few things in 1.4.18 Beta to address this.

1) I added a bit more logging so I'll have a bit more information about what pipe GUID it's trying to connect to. Could you use that version and get me another log?
2) If VC can't connect to the worker process it will kill it so the old process isn't lying around.
3) You can now disable worker process encoding in Options -> Advanced, which may let VidCoder work again for you.
Apr 14, 2013 at 8:37 PM
I really appreciate your good work and your quick response!
Here the log with der 1.4.18 portable (x64) beta:

.. VidCoder (x64)
. Starting job 1/1
. Path: K:\
. Title: 3
. Range: All
. Worker ready: Service state is Opened on pipe 10cd2dc5-b2cf-4070-8e19-1bce71fdf251
. Connecting to process 2280 on pipe 10cd2dc5-b2cf-4070-8e19-1bce71fdf251
. Connection to worker failed after 10 retries. Unable to find endpoint.
. Encode failed.
. Job completed

Apr 14, 2013 at 8:44 PM
Hmm, so it is trying to connect to the correct pipe after the worker process has successfully started up the pipe listener. This is a rather annoying problem. Is there anything different about your system that you think might be causing this?
Apr 15, 2013 at 7:03 AM
Not I would be aware of. It's a Sony Vaio - nothing special. By the way it works with the stable release 1.3.4 (but there is no subtitles function included). Does VidCoder have any other log files which I could send to you?
Apr 15, 2013 at 7:37 AM
No other log files. Have you tried unchecking "Use worker process to encode" in Options -> Advanced?
Apr 15, 2013 at 5:07 PM
Edited Apr 15, 2013 at 5:08 PM
Yep, that worked! Now encoding is running (worker process disabled). Can I do something else to help to find this issue?
By the way: If you exit VidCoder during encoding a null pointer appears. Also pressing stop during encoding does not work.
Apr 15, 2013 at 5:43 PM
Can you try one thing? Open a command prompt and type

net localgroup "NETWORK USERS"

And tell me if your login shows up there.

As for the problems with stopping/exiting, I'll work on getting those ironed out.
Apr 15, 2013 at 5:52 PM
Nope. "System error 1376 has occurred. The specified local group does not exist." appears.
Apr 15, 2013 at 6:43 PM
Okay. One more thing to check. Go to Start -> Services and check to see if Net.Pipe Listener Adapter is running. If it's not running, try starting it.
Apr 15, 2013 at 7:01 PM
The service was disabled. I enabled and started it. With "Use worker process to encode" disabled it worked, but with "Use worker process to encode" enabled it didn't start encoding.
So I disabled the service again.
Apr 16, 2013 at 4:41 AM
Next version will have the stop/exit problems fixed for local encoding. Still looking into the problem you're having with the worker process:
Apr 16, 2013 at 8:54 PM
I downloaded VS 2012 and VidCoder's source. First of all I had to reference Omu.ValueInjecter after downloading it. And then with Net.Pipe Listener Adapter enabled or disabled the following appeared:
Exception in file EncodeProxy.cs in Line 254 (;)

_A first chance exception of type 'System.ServiceModel.EndpointNotFoundException' occurred in mscorlib.dll

Additional information: There was no endpoint listening at net.pipe://localhost/fd655413-ee08-46c3-815d-60802c968e82/VidCoderWorker that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.

If there is a handler for this exception, the program may be safely continued._

Anything special I could try?
Apr 16, 2013 at 10:18 PM
That's enterprising. Press Ctrl+Alt+E and check the "Thrown" column under managed/C# exceptions. Then you can get more information on the EndpointNotFoundException like see if there is an InnerException on it. Or you could try to get a WCF trace of the issue:
Apr 17, 2013 at 8:06 PM
Ok, I don't know if I have done this right. I put the following in the app.config:

  <source name="System.ServiceModel"
          switchValue="Information, ActivityTracing"
      <add name="traceListener"
          initializeData= "c:\temp\Traces.svclog" />

I did the usual but with Net.Pipe Listener Adapter disabled and got a Trases.svclog file. Any chance to send it to you?
Apr 17, 2013 at 8:22 PM
Why did you disable the Net.Pipe Listener Adapter? I'm interested in why it might fail even with that service enabled and running. But yes, please send me that file.
Apr 17, 2013 at 8:30 PM
Because it was disabled before I used VidCoder. Do you recommend to enable and start it automatically?
Sorry, may be it's too late but I can't find your email address anywhere to send the trace to you. Shall I send it to a trash-mail one?
Apr 17, 2013 at 8:33 PM
Edited Apr 17, 2013 at 8:34 PM
You can put it on Dropbox or upload it via some free upload service. If you really want to email it to me you can use the contact user form and I'll reply with my address.

As far as the service, I'd feel a bit better if you kept it on as someone was having similar trouble and it was due to that service not running. I'd prefer to rule that out.
Apr 17, 2013 at 9:00 PM
Ok -> contact user form :-)
Apr 20, 2013 at 1:28 PM
It turned out, that I have to start (portable) VidCoder as administrator. This is pretty unusual and must have something to do with my environment.
Case closed :-)
May 20, 2013 at 2:59 PM
Edited May 20, 2013 at 3:01 PM
I hope its ok to "borrow" this thread,
hence it
s almost the same problem i had after updating to latest version vidcoder

Got the Unable to find endpoint, never experienced it in the "old" version though.

It wasnt while converting to .mp4 but when converting from 1080p to 720p .mkv files.

m Running Win 7 Enterprise x64
  • Starting queue
    -- VidCoder (x64)
  • Starting job 1/1
  • Path: F:\Some.mkv.file
  • Title: 1
  • Range: All
  • Worker ready: Service state is Opened on pipe VidCoderWorker.0a23b9cf-8403-4e76-962e-7db4a3355f61
  • Connecting to process 4760 on pipe VidCoderWorker.0a23b9cf-8403-4e76-962e-7db4a3355f61
  • Connection to worker failed after 10 retries. Unable to find endpoint.
  • Encode failed.
  • Job completed
  • Queue completed
  • Generating preview clip
  • Path: C:\Users\Bente\AppData\Local\VidCoder\preview.mkv
  • Title: 1
  • Preview -: 1
  • Worker ready: Service state is Opened on pipe VidCoderWorker.2a1d82ba-de5c-466a-92b1-f79ccaa10eac
  • Connecting to process 4876 on pipe VidCoderWorker.2a1d82ba-de5c-466a-92b1-f79ccaa10eac
  • Connection to worker failed after 10 retries. Unable to find endpoint.
  • Preview clip generation failed
After following the advice given from RandomEngy "unchecking "Use worker process to encode" in Options -> Advanced?"

it`s functioning as supposed again.:-)

May 20, 2013 at 4:02 PM
4Who, do you have any Garmin software installed? Some software interferes with the named pipes that VidCoder is using to communicate with the worker process.
May 20, 2013 at 5:23 PM
Yes i have garmin soft installed, Garmin express, basecamp and webupdater,
it didn`t interfere with the other "old" version i had.?

May 20, 2013 at 6:18 PM
In VidCoder 1.3 all the encoding happened inside the GUI process. This wasn't great because if the HandBrake core crashed while doing the encode, the whole GUI would crash and nothing queued after that would complete. VidCoder 1.4 has a new feature where all the encoding happens in a worker process: if the encode crashes, it will nicely report the crash and continue on to the next item. It uses named pipes to communicate with the worker.

However the Garmin software is designed poorly and takes over every named pipe endpoint, which breaks many other programs (Including VidCoder 1.4). I've reported the problem to them and they say it will be fixed in Garmin version 2.2.x.
Sep 26, 2013 at 4:18 PM
Edited Sep 26, 2013 at 4:19 PM
In case you're interested, I just starting having this problem after using Vidcoder for quite some time without issue. I'm using Win 8 x64 and I do not have any Garmin software installed. Unchecking the "Use worker process" option restores normal functionality.
Sep 26, 2013 at 4:25 PM
Hmm. Can you post a log? There might be something interesting in it. That would also tell me if you're using the Stable or Beta version. I think I worked out all the issues in the previous release; there may be some other piece of software interfering.
Sep 26, 2013 at 4:31 PM
Interesting, I edited my post above but the change didn't seem to stick. Anyway, the problem appears to be with a program called Dimmdrive ( It only started happening after I installed it, I removed it and tried Vidcoder again with the "Use worker process" enabled and now it works again.
Sep 26, 2013 at 4:36 PM
Thanks for the follow-up! Good to know what pieces of software do that.