This project is read-only.

VidCoder just stops with No Error - Need Help! (long post)

Jun 24, 2013 at 7:17 PM
Edited Jun 24, 2013 at 7:29 PM
Hi everyone,
This is my first post, so go easy on me if I make any mistakes. :) I will apologize up front for the length. I am just not sure what is important for the group to know and what is not, so I am giving you all the detail I can.

I have been using VidCoder for about 1-1/2 years now with virtually no problems whatsoever. I am currently using the latest version (1.4.22) and the .9.9.9 version of HandBrake with the latest nightly build as of yesterday. I really like the program, I use it mostly to encode Cable TV shows via Windows Media Center in the .WTV format to a small screen .MP4 format for viewing. I really like the software and would like to continue using it. However, I have recently ran into problems where VidCoder just stops encoding with no error messages or anything. VidCoder does not crash, it just stops. The progress bar will stop making any "progress". I have given it plenty of time (like even overnight) to make sure it was not just slow, but I would come in the next morning and it would be right at the same percentage of completion that it was when I left it the night before! I tried to "Stop" the particular file it was encoding, but when I attempted to do so, VidCoder would hang and stop responding at that point. The only way to close the program at that point was to use task manager.

With Task Manager, previously I would first close the VidCoder application, which would stop the VidCoder.exe process. Then I would stop the VidCoderWorker.exe process which would then close out the application. For a while, I thought it was only happening on HD recordings, so I stopped recording in HD. Today however, it happened again on a SD recording. This time, instead of ending the VidCoder application first, I went straight to the VidCoderWorker.exe process and selected "End Process Tree". VidCoder behaved entirely different. Instead of closing, it just closed the problem file, taking it out of the Queue, and resumed encoding on the next file in the list. VidCoder never closed, it just reloaded both processes and continued! What the heck? I have never seen a program do that! UPDATE: must have been a fluke as I have not been able to repeat that behavior again.

Whatever, the bigger issue is why VidCoder is stopping in the middle of encoding a file? The problem seems to have started with this last 1.4.22 upgrade. When I initially did the upgrade, my HandBrake version was .96. The problem was happening with this version, but as soon as I discovered that, I did the upgrade immediately but it is not making any difference. I have also tried reinstalling earlier versions with no success either.

I am at my wit's end with this! I used to be able to put several files in the queue, and go to bed with confidence that VidCoder would do the encoding overnight and in the morning I would have my endoded files ready. Sometimes, VidCoder would not be able to handle one or more of the encodings, but would always put up the red "!" letting me know it had a problem with that file. It would not stop at that point however, but would go on to the next file and continue. This is the behavior I have come to rely on. Now, it just stops. If it happens early in the queue, nothing below it gets processed. This has become a big problem and a huge time waister.

Does anyone have any ideas what might be causing this problem? Is anyone ELSE having issues like this? I appreciate any and all comments. BTW, there have been no recent changes to my PC configuration. It is the same as it was for the last 12-months: Windows 7 Home Premium running on a Dual Core Intel processor with 4GB RAM. Source and destination files are over my Windows Home Server (V1) network via remapped drives.

Thanks everyone!

PS: I can supply images of my VC settings screens if anyone would like to see them.

UPDATE: Since I wrote (but not yet posted) the above, I stumbled upon a post from another member that said he had the same problem, but did not have the problem when he was using HB .9.8. So, I uninstalled VC, VC Beta, and HB, rebooted the PC and installed HB .9.8 first and only VC 1.4.22. I setup a queue before going to bed last night with about 10 .wtv files in it, the last one being one of the files I had problems with before. This morning I checked the results and found 8 successful encodings, 1 failure and VC hung on that last file - no error, no anything. Task Mge shows both processes still working but the progress bar never moves. If that file had been first on the list in the queue, none of the other 9 files would have been processed. Just for the record, that last .wtv file plays just fine in its native format. DANGIT! I am a very experienced, somewhat advanced PC user since the old CPM days. I can usually figure out these things myself, but I just cannot find a solution to this issue. Very frustrating to say the least. Thanks again for your help, everyone.

Here is the Log for the PREVIOUS file it stopped endoding on (not the one in the update):

[I ran out of allowable characters, so I will try to put the Log file is in another post or reply if it will permit me to do so]
Jun 24, 2013 at 7:23 PM
Edited Jun 24, 2013 at 7:25 PM
Here is the Log for the PREVIOUS file it stopped endoding on (not the one in the update) Sorry about the HUGE font size, I don't know why that is happening:

COMMENT: It looks to my untrained eye, like VC (or HB) is trying to p[rocess this .wtv file as thought it were a DVD and failing (obviously) to do so.

VidCoder (x86)

Starting scan: V:\Ancient Discoveries_HISI_2013_06_20_06_59_00.wtv

[22:35:15] hb_init: starting libhb thread
[22:35:15] hb_scan: path=V:\Ancient Discoveries_HISI_2013_06_20_06_59_00.wtv, title_index=0
libbluray/bdnav/index_parse.c:162: indx_parse(): error opening V:\Ancient Discoveries_HISI_2013_06_20_06_59_00.wtv/BDMV/index.bdmv
libbluray/bdnav/index_parse.c:162: indx_parse(): error opening V:\Ancient Discoveries_HISI_2013_06_20_06_59_00.wtv/BDMV/BACKUP/index.bdmv
libbluray/bluray.c:1725: nav_get_title_list(V:\Ancient Discoveries_HISI_2013_06_20_06_59_00.wtv) failed (00BED4E0)
[22:35:15] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 4.1.3
libdvdread: Encrypted DVD support unavailable.
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[22:35:16] dvd: not a dvd - trying as a stream/file instead
[mpeg2video @ 00C2BA80] mpeg_decode_postinit() failure
[mpeg2video @ 00C2BA80] mpeg_decode_postinit() failure
[mpeg2video @ 00C2BA80] mpeg_decode_postinit() failure
[mpeg2video @ 00C2BA80] mpeg_decode_postinit() failure
[mpeg2video @ 00C2BA80] mpeg_decode_postinit() failure
[mpeg2video @ 00C2BA80] mpeg_decode_postinit() failure
[mpeg2video @ 00C2BA80] mpeg_decode_postinit() failure
[mpeg2video @ 00C2BA80] mpeg_decode_postinit() failure
[mpeg2video @ 00C2BA80] mpeg_decode_postinit() failure
[mpeg2video @ 00C2BA80] mpeg_decode_postinit() failure
[mpeg2video @ 00C2BA80] mpeg_decode_postinit() failure
[mpeg2video @ 00C2BA80] mpeg_decode_postinit() failure
[mpeg2video @ 00C2BA80] mpeg_decode_postinit() failure
[mpeg2video @ 00C2BA80] mpeg_decode_postinit() failure
Input #0, wtv, from 'V:\Ancient Discoveries_HISI_2013_06_20_06_59_00.wtv':
WM/MediaClassPrimaryID: db9830bd-3ab3-4fab-8a371a995f7ff74bÂ<Ä,ÆÈÊÌÎÐÒ    ÔÖY×Ó:)u
WM/MediaClassSecondaryID: ba7f258a-62f7-47a9-b21f4651c42a000e
Title           : Ancient Discoveries
WM/SubTitle     : Rituals of Death
WM/SubTitleDescription: The mummified crocodiles of Kom Ombo; using an X-ray on an ancient mummy; China's terra-cotta army; scientists solve 
a year-old murder using 15th-century forensics; virtual-reality techniques afford investigation of crucifixion.
genre           : Documentary;General;Educational;Series;Documentary/Bio;Other
WM/OriginalReleaseTime: 0
WM/MediaCredits : ;;;
service_provider: HISI
service_name    : H2
WM/MediaNetworkAffiliation: Satellite
WM/MediaOriginalChannel: 325
WM/MediaOriginalChannelSubNumber: 0
WM/MediaOriginalBroadcastDateTime: 2009-12-22T08:00:00Z
WM/MediaOriginalRunTime: 37172304688
WM/MediaIsStereo: false
WM/MediaIsRepeat: true
WM/MediaIsLive  : false
WM/MediaIsTape  : false
WM/MediaIsDelay : false
WM/MediaIsSubtitled: false
WM/MediaIsMovie : false
WM/MediaIsPremiere: false
WM/MediaIsFinale: false
WM/MediaIsSAP   : false
WM/MediaIsSport : false
WM/ParentalRating: TV-PG
WM/Provider     : MediaCenterDefault
WM/VideoClosedCaptioning: true
WM/WMRVEncodeTime: 2013-06-20 13:59:02
WM/WMRVSeriesUID: !MCSeries!48219286
WM/WMRVServiceID: !MCService!28455593
WM/WMRVProgramID: !MCProgram!225264875
WM/WMRVRequestID: 0
WM/WMRVScheduleItemID: 0
WM/WMRVQuality  : 2
WM/WMRVOriginalSoftPrePadding: 360
WM/WMRVOriginalSoftPostPadding: 60
WM/WMRVHardPrePadding: -300
WM/WMRVHardPostPadding: 0
WM/WMRVATSCContent: true
WM/WMRVDTVContent: true
WM/WMRVHDContent: false
Duration        : 36576484375
WM/WMRVEndTime  : 2013-06-20 15:00:00
WM/WMRVBitrate  : 3.400029
WM/WMRVKeepUntil: 0
WM/WMRVActualSoftPrePadding: 357
WM/WMRVActualSoftPostPadding: 0
WM/WMRVContentProtected: false
WM/WMRVContentProtectedPercent: 0
WM/WMRVExpirationSpan: 9223372036854775807
WM/WMRVInBandRatingSystem: 255
WM/WMRVInBandRatingLevel: 255
WM/WMRVInBandRatingAttributes: 0
WM/WMRVWatched  : false
WM/MediaThumbWidth: 352
WM/MediaThumbHeight: 240
WM/MediaThumbStride: 1056
WM/MediaThumbRet: 0
WM/MediaThumbRatingSystem: 9
WM/MediaThumbRatingLevel: 10
WM/MediaThumbRatingAttributes: 0
WM/MediaThumbAspectRatioX: 4
WM/MediaThumbAspectRatioY: 3
WM/MediaThumbTimeStamp: 4640471923627896116
WM/MediaThumbType: 3
Duration: 01:00:56.88, start: 1.723156, bitrate: 3400 kb/s
Stream #0.0[0x46](eng): Audio: ac3, 48000 Hz, stereo, fltp, 192 kb/s
Stream #0.1[0x47](spa): Audio: ac3, 48000 Hz, stereo, fltp, 192 kb/s
Stream #0.2[0x48]: Video: mpeg2video (Main), yuv420p, 704x480 [PAR 10:11 DAR 4:3], 15000 kb/s, 23.98 fps, 29.97 tbr, 10000k tbn, 59.94 tbc
Stream #0.3[0x49]: Subtitle: [0][0][0][0] / 0x0000
Stream #0.4[0x0]: Attachment: mjpeg
  title           : TV Thumbnail
[22:35:16] add_ffmpeg_subtitle: unknown subtitle stream type: 0x17007
[22:35:16] scan: decoding previews for title 1
[22:35:16] scan: audio 0x1: AC-3, rate=48000Hz, bitrate=192000 Espanol (AC3) (2.0 ch)
[22:35:16] scan: audio 0x0: AC-3, rate=48000Hz, bitrate=192000 English (AC3) (2.0 ch)
[22:35:16] scan: 10 previews, 704x480, 23.976 fps, autocrop = 34/58/0/0, aspect 4:3, PAR 10:11
[22:35:16] libhb: scan thread found 1 valid title(s)

Scan completed

Jun 24, 2013 at 7:32 PM
Does HandBrake 0.9.9 also hang at the same spot?
Jun 24, 2013 at 10:39 PM
I am now running HB 0.9.8 with VC 1.4.22. I never tested with HB alone. I only use HB because of VC. I never could get to a comfortable level of understanding with HB, so VC was the perfect solution for me. ALSO, it never hangs in exactly the same spot. I have tried the same file at least 4 times, and it hangs at like around o.4%, 37.6%, 76.7%, and 99.8%. No pattern of repeatability that I can see. Do I really need to go into HB and just force myself to bite the bullet and "test" that way? I know it would prove who is at fault, but am I alone with this problem? Or, is it maybe a Windows .wtv problem? If you look at the log file, it appears that VC (or HB) is trying to read the .wtv file as though it were a DVD. That may be the problem, but I don't know what to do about that. Any comments?

Thanks so much for your assistance,
Jun 24, 2013 at 10:49 PM
Well when things go wrong with encoding (in your case a hang) sometimes it's my fault and I'm not calling the HandBrake library correctly and sometimes it's just a bug in HandBrake itself. Testing with HandBrake is the best way to tell who has the problem. Also if it is a HandBrake problem, I cannot help you; you have to report the problem to them.

As for your question about why the UI did not close when you killed VidCoderWorker.exe, that's a feature in VidCoder. If the encoding process crashes (or is killed), the UI process (VidCoder.exe) will detect this, mark the encode as failed and move on to the next item in the queue. So a problem with encoding one item won't bring down the whole queue.
Jun 25, 2013 at 2:26 AM
OK then, when I get home tonight I will stumble through HB and run an encoding on the same file and see if it completes. I just hope I get all the settings correct. Every time I have tried to use HB in the past, I found it quite confusing, which is why I have liked using VC so much.

I am puzzled by the fact that everything was working just fine when I was using VC 1.4.20 (might have been 1.4.21) and HB 0.9.6. Everything seemed to change when I did the upgrade to 1.4.22. Problem is I have tried to go BACK to VC 1.4.20 & HB 0.9.6 and I still have the problem. The upgrade must have changed something else that is causing this to happen. VC is not a program I can rely on right now if it just hangs without throwing an error and does not go on to the next file in the queue.

BTW: you did not comment on my Log observation that VC might be trying to read the .wtv file as a DVD. Do you have any comments on that perhaps?

Thanks again,
Jun 25, 2013 at 2:34 AM
Well I'm glad you like VidCoder's interface! If you want to avoid HandBrake you can send me the preset you used and the source file and I'll see if I can reproduce the issue.

About reading the .wtv file as a DVD, that's normal behavior for HandBrake. It always tries loading as a DVD then falling back to a file mode.
Jun 25, 2013 at 4:31 AM
Well, I would prefer to send you the preset & source file. Problem is, the source file is almost 1.6GB large. I am not sure if Gmail will allow me to send a file that size or if you can receive one if I could. Do you happen to know if GMail will allow it? Can you receive it?
Jun 25, 2013 at 4:36 AM
You can share large files easily with utorrent. Just remember to enable utorrent remote access in Preferences -> Remote.
Jun 25, 2013 at 5:22 AM
OK thanks. One more question: where does VC store the preset files in Win7? I can't seem to find them.
Jun 25, 2013 at 6:37 AM
Inside %appdata%\VidCoder\VidCoder.sqlite . The easiest way to get at a preset is export it to an .xml file.
Jun 26, 2013 at 4:22 AM
Thanks, but I got impatient and decided to take a whack at HB. I went through all the settings and set them all identical to the ones in VC. Well, HB completed the encoding just fine and the resulting .mp4 file plays perfectly with VLC. Also, it SEEMED like HB was encoding faster than VC did, which runs contrary to reports I have read from other users. I ran that same file through VC at least 3 maybe 4 times and it would hang every time in different places. I guess that points to it being a VC problem right? OK, now tell me what I can do to help you fix this, because I still do not like using HB.
Thanks again,
Jun 26, 2013 at 5:29 AM
A HandBrake log and a VidCoder log of the same encode might be helpful. The original file and preset would be the biggest help.
Jun 26, 2013 at 7:02 PM
I can do that, but it is something I have never done before, and I am not that technically familiar with the process. I have never been a beta tester. SO, bear with me as I stumble through this.

I downloaded that uTorrent thing but I did not see a clear way to send a file just to YOU. How exactly does that work??? I am not presently a uTorrent user nor do I even do the bittorrent thing at all. Historically, I have been sort of afraid of using it. It seemed kind of like I was doing something wrong and I was afraid of being caught or at the least getting viruses. I guess there are legitimate uses of it but it seemed like it was being primarily used to share DRM content.

I'm thinking of re-encoding that file again on VC and HB and sending everything to you afterwards. Is it possible to clear the logs just prior to doing that? If you can answer all these questions and walk this novice through this process I would be more than happy to help.
Jul 1, 2013 at 8:28 AM
Sorry for the delay.

That should tell you how to share files. You won't get into trouble for just sending a sample file to me.
Jul 16, 2013 at 12:12 AM
Didn't mean to just drop you, but the problem seems to have corrected itself (is that even possible?). Have encoded some 50+ files since my last post and only had one incident of VC just "hanging" without finishing. I had 3 "Failures" that finished fine on each re-try. I am now suspecting that there is just something wrong with those few files that VC can't deal with. I have isolated 2 of them that I can still forward to you if you want to. But as far as I am concerned, the issue is at tolerable levels. Let me know if you want those files or if you want me to send the file AND the Logs the NEXT time it happens. Let me know and I will do my best to help you.
Jul 16, 2013 at 12:27 AM
Forgot to mention, I went back to VC 1.3.4 and HB 0.9.8, so maybe that helped.
Jul 16, 2013 at 12:35 AM
Sure, send the files and logs/exported preset and I'll take a look at them.
Jul 16, 2013 at 1:17 AM
OK, here's what I will attempt to do. When I get home tonight, I will re-run the last file that stopped AGAIN, by itself, and see what happens. If it hangs, I will send you the file, logs & exported preset. That OK?
Jul 16, 2013 at 1:19 AM
Aug 2, 2013 at 5:14 PM
Just thought I would update you and let you know why you haven't heard from me. Reason is, I have not had a single instance of stoppage. I am currently running VC 1.4.22 and HB 0.9.8. I have had a FEW (very few) red "!"'s that re-encoded fine on second try, but not a single hang. I have encoded close to 100 or so files since my last post and all seems to be working fine.

I did notice on the Downloads page that you have released Stable VC 1.2.3. Plus, there is a new HB available 0.9.9. Naturally, I am reluctant to change anything, but I seem to remember something in the past about my VC version "Expiring" and being forced to do an upgrade. Is this still the case?

Also, I am very curious if anyone else has had these stoppage issues, and which versions were involved.

Thanks so much, and keep up the great work!
Aug 2, 2013 at 5:30 PM
VidCoder versions don't expire. You can just turn off automatic updates and keep using the version you have forever.
Aug 3, 2013 at 2:10 AM
unsubscribe RandomEngy wrote:
Aug 3, 2013 at 5:19 PM
Thanks, I guess I haven't explored all the options sufficiently. Three more questions:
  1. At some point, can I assume it would become "necessary" to upgrade?
  2. Is it possible to install second instances of later versions of VC & HB in some kind of SandBox as a test for newer releases?
  3. Has anyone else has had these stoppage issues, and which versions were involved? If so, were they able to determine a cause & fix? Purely academic at this point in time, but could become relevant if the problem resurfaces.
Thanks so much!
Aug 3, 2013 at 6:02 PM
1) At no point am I going to force anybody to upgrade. You just won't get new features or bugfixes if you opt out of upgrading.
2) You can install VidCoder stable and Beta side-by-side, but you cannot install two releases from the same track side-by-side. You could use the portable versions to test though, since those are not installed.
Aug 4, 2013 at 6:02 AM
Thanks a bunch! That portable version idea sounds like a good one.