This project is read-only.

MKV on Popcorn Hour

Jan 16, 2015 at 10:46 AM
Hi there,

I recently started converting BluRays, and used BDtoAVCHD, which worked quite alright, but is -after years- still not capable to do more than one language/subtitle.

So I found VidCoder, which is awesome, but it seems to have a flaw for me: the created mkv's will not play on my Popcorn Hour A110. I know, the device is a bit old, but just until now it did all it had to do. I looked at the BDtoAVCHD and VidCoder mkvs in MediaInfo, fiddled around with the video settings until they were the same, but to no avail. The onyl difference I can now see that is left is the toolset that creates/muxes(?) the mkv.

In BDtoAVCHD I see
Writing application: mkvmerge v7.4.0 ('Circles') 32bit built on Dec 12 2014 12:10:09
Writing library: libebml v1.3.0 + libmatroska v1.4.1

In VidCoder I see
Writing application: HandBrake 6548svn 2014112401
Writing library: Lavf55.12.0

Could this be the reason for the mkv file not mounting correctly? So I went and ran the VidCoder mkv through mkvtoolnix, with no modifications, just to have it remuxed.
Now it mounts, but the subtitles won't play...

Any ideas (except for buying another device)?
Jan 19, 2015 at 10:15 PM
Edited Jan 19, 2015 at 10:18 PM
For anyone interested, I may have found the reason.

It seems to have been around for a while. It has to do with matroska header compression:

No way currently to switch it off:

If you know if it can be switched off, please give me a hint. :)
Jan 29, 2015 at 8:17 PM
Not an overly active community here, methinks :::

Had a nice chat with a few guys on the Handbrake IRC channel. Basically, it must have been the switch from libmkv to libavformat (from 0.9.9 to 0.10).


Edit: just for the record: I will now dump my "old" Popcorn Hour A-110, just bought an Intel NUC, will deploy OpenELEC on it.